0

I am working, which has around 40 employees and almost everyone is using ubuntu desktop 14.04. I have created a local ubuntu repository(ubuntu 14.04) using apt-cacher. I am using it for updating systems and installing new softwares in all the ubuntu systems.

I have updated few of the systems from 14.04 to 16.04 using it. Now when I am trying to install new packages in the updated systems(16.04), it is not happening. I am getting the following error:

Ign http://192.168.1.2:3142 trusty/main Translation-en
Err http://192.168.1.2:3142 stable/main i386 Packages
404 Not Found Fetched 3,356 kB in 36s (90.9 kB/s)

E: Some index files failed to download. They have been ignored, or old ones used instead.

Please make a note that 192.168.1.2 is the local IP of my apt-cacher server.

As all of my systems are not upgraded to 16.04, I want to keep my apt-cache server for 14.04 as well as 16.04. How can I achieve this? Further can I make it the repository of packages which are installed using ppa?

  • You need to add the packages for xenial to your repo. – grooveplex Aug 5 '16 at 14:02
0

I believe you need to change the option "distinct_namespaces = 1".

Did you use the path_map option? I think there is some thing wrong with this. I tried to modified in several ways the path_map e just don't work. When i tried without path_map, works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.