0

I was curious and installed GNOME desktop environment alongside with Unity. Then I felt it's not the flavor I like. I already uninstalled it by doing a complete removal via Synaptic Package Manager. However, the process of uninstalling was very quick compared to the installing process. It seemed that the 'complete removal' happened to be 'incomplete removal'. Till now, I am still given options to choose which desktop environment I want to use (whether it's Unity as the default environment or some other types of GNOME) whenever my laptop is opening the login window. I don't like it. How do I get rid of this space-consuming GNOME entirely (it said over 500 MB space required)?

  • Running the command sudo apt autoremove might help. – Gunnar Hjalmarsson Aug 4 '16 at 23:55
  • This looks like a duplicate of the question you asked a couple of hours ago? – thomasrutter Aug 5 '16 at 0:11
  • Ah I see, this one was asked after you attempted a removal and are still finding problems. Since it's kind of about the same issue, you could probably have updated your previous question with an edit, to show what you tried and what problems remain. – thomasrutter Aug 5 '16 at 0:13
  • @thomasrutter: Different OPs and different issues. ;) – Gunnar Hjalmarsson Aug 5 '16 at 0:14
0

If GUI is troubling you, login through CUI(Ctrl+Alt+F1)

Check if "ppa-purge" package is installed or not.

Run

dpkg -l | grep ppa-purge

If it returns the value, "ppa-purge" is installed. If not, install it as follows;

sudo apt-get install ppa-purge

After that run the following commands;

sudo ppa-purge ppa:gnome3-team/gnome3-next
sudo ppa-purge ppa:gnome3-team/gnome3-staging
sudo ppa-purge ppa:gnome3-team/gnome3

sudo apt-get remove gnome-shell ubuntu-gnome-desktop

Reboot system and login through Unity.

  • I forgot to mention that it's running 14.04.4. So, I need to make sure first whether the GNOME that I have installed is GNOME 3. Sorry, but I no nothing about GNOME versions and their compatibility with Ubuntu releases. – LuMINTu Aug 4 '16 at 23:58
  • I did as suggested. However, there are still options in the login windows that weren't removed. – LuMINTu Aug 5 '16 at 1:50
  • This answer assumes Op added third party repositories, which is not stated in the question, and also removing and reverting a PPA repository wouldn't "remove" gnome. – xangua Aug 5 '16 at 2:05
  • There had been GNOME, GNOME Classic, GNOME Flashback (Compiz), GNOME Flashback (Metacity), and Unity (Default). After those given commands applied, now there are: GNOME Flashback (Compiz), GNOME Flashback (Metacity), and Unity (Default). Thank you @sir_smiggles However, I want those 2 GNOME Flashbacks gone too like the first two GNOMEs. I want the Unity back as the one and only Desktop Environment for my laptop. – LuMINTu Aug 5 '16 at 2:24
0

I'd like to share an experience that happened to solve problem. I went to Synaptic Package Manager and typed 'GNOME Flashback' on its 'rebuilding search index' space. Then it showed me some file packages which had been installed including a package named 'gnome-session-flashback'. I did a complete removal to it. Soon after that I restarted my laptop. Then, voila! There were no other desktop environments I had to pick but my one and only Unity. Thank you for your support, people! I've got what I want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.