4

That command below worked fine on Ubuntu 14.04. After upgrade to 16.04 it does not work anymore. It opens a terminal window with 4 tabs.

open-terminals.sh

#!/bin/bash
gnome-terminal --load-config=terminal-config.cfg &>/dev/null &

terminal-config.cfg

#Written by GNOME Terminal 3.6.2

[GNOME Terminal Configuration]
Version=1
CompatVersion=1
Windows=Window0;

[Window0]
MenubarVisible=true
Role=gnome-terminal-window-6355-887453268-1466588933
ActiveTerminal=Terminal0xed4f70
Geometry=135x24+437+495
Terminals=Terminal0xe04970;Terminal0xc1f520;Terminal0xe4f060

[Terminal0xe04970]
ProfileID=Default
Title=am.example.com
WorkingDirectory=/home/.../servers/apache-tomcat-am/bin
Zoom=1
Width=135
Height=24

[Terminal0xc1f520]
ProfileID=Default
Title=web.example.com
WorkingDirectory=/home/.../servers/apache-tomcat-web/bin
Zoom=1
Width=135
Height=24

[Terminal0xe4f060]
ProfileID=Default
Title=middleware.example.com
WorkingDirectory=/home/.../servers/payara-middleware/bin
Zoom=1
Width=135
Height=24

[Terminal0xed4f70]
ProfileID=Default
Title=api.example.com
WorkingDirectory=/home/.../servers/glassfish-api/bin
Zoom=1
Width=135
Height=24

At first I got a "Error creating terminal: "Default" is not a valid UUID" error. I fixed it so that I put a real uuid to ProfileIDs.

Next error what I got was "Error creating terminal: No profile with UUID "e4661004-d5fd-4d17-9a9d-8e419b6b8330" exists". I fixed it so that I changed the value of Terminals in [Window0] to the ProfileIDs.

Next problem: Title and WorkingDirectory properties are not applied and i just realized that the "rename tab" menu is disappeared from the menu.

GNOME Terminal

3.18.3

A terminal emulator for the GNOME desktop

Using VTE version 0.42.5 +GNUTLS

Could you please help me to fix this issue?

update

gnome-terminal --save-config=~/temp/xyz.cfg says that Option "--save-config" is no longer supported in this version of gnome-terminal.

What is that? What is is the alternative way to do the same with the new version of gnome-terminal? I have not found any useful about this topic on the internet :(

1

Same issue.

On my computer the command line parameter --tab-with-profile accepted value "Default", while --load_config did not (check tag <entry name="visible_name"> in the file ~/.gconf/apps/gnome-terminal/profiles/Default/%gconf.xml or use GUI profile settings).

So I have transformed important values from the config file to command line parameters. You can use following code for your setup:

gnome-terminal --geometry="135x24+437+495" \
            --tab-with-profile="Default" --working-directory="/home/.../servers/apache-tomcat-am/bin" \
            --tab-with-profile="Default" --working-directory="/home/.../servers/apache-tomcat-web/bin" \
            --tab-with-profile="Default" --working-directory="/home/.../servers/payara-middleware/bin" \
            --tab-with-profile="Default" --working-directory="/home/.../servers/glassfish-api/bin"

Unfortunately I haven't found how to set tab titles this way.

But there are sweets in the end. You can use --command for each tab and run e.g. mc. This was impossible with config file.

0

I've got same issue. Partly fix is to comment all lines where

ProfileID=Default

...it provides load all your tabs from configuration saved before. But tab name issue should be fixed (I've checked --help & --help-all - have not found correct property for tab title)

Other way to have hot fix is to replace ProfileID name value with id value. Id value can be checked in Edit->Profile parameters->General->profile ID.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.