I have a 4k resolution screen and the display resolution shows: 3840x2160. I do not want to reduce this resolution. Here is the problem:

I see extremely small fonts, I need to touch my nose to the screen to see when:

  1. I login for the first time after a fresh install of Kubuntu 16.04
  2. Login screen after reboot or logoff
  3. I install applications like Skype, Gedit, Matlab (img below)
  4. grub loader screen
  5. Small icons when looking through the system menu etc. (img below)

Solutions found:

  1. Goto K button>System Settings>Font>Force Fonts DPI = 230
  2. None yet
  3. None Yet
  4. Alter the resolution in /etc/default/grub
  5. None Yet

Kindly help!


Small fonts in apps

Small icons

System Specifications: Kubuntu 16.04, Dell Precision 5510 4k touch screen with NVIDIA Quadro M1000M

  • Unrelated to your question, but does suspend/resume work for you on kubuntu 16.04? askubuntu.com/q/820955/94764
    – ytjohn
    Sep 6, 2016 at 0:40
  • 1
    In KDE "System Settings" -> "Display" you can find a "Scale" Option at the bottom. Set to 2 or higher and you should be fine. Tested on Kubuntu 17.10. Mar 21, 2018 at 10:28

4 Answers 4


Maybe this link helps: Is Ubuntu 4K ready?

This german article says that it was running without issues. The author describes that he was changing the scaling factor under the system preferences and that the scaling was set systemwide for all used fonts.

Kubuntu should probably also have a scaling factor in the settings but I don't know where.


You can use Unity Tweak Tool in Ubuntu 16.04 LTS and 18.04 LTS. The settings I'm using for scaling on a 1920x1080 monitor are:

Tweak fonts.png

The Text scaling factor scales both fonts and UI elements like title bars, menus, etc.

Icon size is preset but the text size under it increases giving the illusion the icon size changed:


In the .gif above scaling starts at 1.38 on a 1920x1080 monitor. Then it is changed to 1 and everything gets tiny, which is normal. Then it is changed to 2 which is ideal for the visually challenged. Once again the icons have fixed pixel size and the font shrinking or expanding under the icon gives the illusion their size is changing.

To install Unity Tweak Tool use:

sudo apt install unity-tweak-tool

Others may be interested in the full suite of tools available in 18.04 LTS:

$ apt list | grep tweak
gajim-rostertweaks/bionic,bionic 1.0.0-3 all
gnome-tweak-tool/bionic,bionic 3.28.1-1 all
gnome-tweaks/bionic,bionic 3.28.1-1 all
mate-tweak/bionic,bionic 18.04.16-1 all
mousetweaks/bionic,bionic,now 3.12.0-4 amd64 [installed]
tweak/bionic 3.02-2 amd64
unity-tweak-tool/bionic,bionic,now 0.0.7ubuntu4 all [installed]

I can't add comments on here yet, but the German article is about Ubuntu and Gnome is doing a much better job at scaling its interface via a change to one setting.

Here is what works on Kubuntu

  1. Determine your screen DPI (official foc or with a tester). For me it's 282
  2. Create a file which tells X what the DPI is

      # sudo nano /etc/X11/Xsession.d/77set_dpi
  3. Type the following line using your DPI. Mine was 282

      xrandr --dpi 282x282
  4. Save file
  5. Create another file which tells X what the DPI is

      # nano ~/.Xresources
  6. Type the following line using your DPI. Mine was 282

      Xft.dpi: 282
      Xft.autohint: 0
      Xft.lcdfilter: lcddefault
      Xft.hintstyle: hintslight
      Xft.hinting: 1
      Xft.antialias: 1
      Xft.rgba: rgb
  7. Save file
  8. Open the KDE menu, type display, pick "Display Configuration"
  9. Click on "Scale Display"
  10. Adjust to your liking. I don't think there is a rule here
  11. Reboot
  12. Right-click on your task bar -> Panel options -> Panel settings
  13. Click and hold the "Height" button, move up until it looks good

(Adapted from https://www.girialam.com/2016/02/kubuntu-and-hidpi-screen/)

I found that 240 worked best with the Precision 5510. 282 is just too big


You can adjust scaling etc if you hold magnifying glass up to screen but it is a pity it loads up so small initially.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.