4

I've been scratching my head over this for hours now and still can't pinpoint where the problem is coming from.

Basically, the desktop environment takes ages to load on startup and anything which has to do with Mate (panels, application menu, contextual menu, etc...) is slow and laggy (to a crawl). What I don't get is what could possibly have caused this.

The problem literally popped out of nowhere, and after trying to narrow it down, I noticed it comes from the user profile or something in /Home.

With /root being on btrfs, I reverted to an earlier snapshot in an attempt to fix this, but the problem clearly didn't come from the system as it was still existent after the rollback.

This left me with /home (ext4 file system) to test, so I created a new user and logged in with this user. The problem was gone, Mate lightning quick as expected.

I'm running Ubuntu 16.04 Mate (64 bit). Fully updated. No third party software installed except VMware player. Standard ambiance theme (not tweaked). Running 4.4.0-31-generic kernel. 2015 MSI GT72 Gaming Laptop. Using NVIDIA Drivers as default. Macro window manager, Compton for compositing using the GPU (already tried switching to Compiz or software compositing, but didn't fix the issue).

here is the output of systemd-analyze blame:

Screenshot

Here is the output of top:

Screenshot

Here is the output of lspci -k | grep -EA2 'VGA|3D':

01:00.0 VGA compatible controller: NVIDIA Corporation GM204M [GeForce GTX 970M] (rev a1)
Subsystem: Micro-Star International Co., Ltd. [MSI] GM204M [GeForce GTX 970M]
Kernel driver in use: nvidia

I'm posting this question because I'm desperate for a solution. Google didn't help, I hope you gents/ladies can.

Thank you for taking the time to read.

  • Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command. – Pilot6 Aug 4 '16 at 20:30
  • added the output of lspci – Bamoka Aug 4 '16 at 20:34
  • This is a mystery. I had this too on one computer and never had anywhere else. It is not driver dependent. I gave up to solve this puzzle. – Pilot6 Aug 4 '16 at 20:35
  • 1
    I'd probably see if .config, .cache or .local are involved. So for example rename .config to .config.bak & log out/in or restart & see if any different. If not then try the same with .cache, then .local. If the situation improves then look at what's in the causing folder, ect. – doug Aug 4 '16 at 20:55
  • I'm just sitting in the same boat, but the approach by Doug and Bamoka doesn't fit. Dug deeper and found out the kernel completely ignores the swappiness set, behaving like it was set to 100 (ie. "swap as soon as you can"): from 8G RAM, only 2 are used, with 3G in swap. So as soon as I switch, it has to "swap in" what I switch to. Doing nothing for ~5min means almost everything is swapped out. Not even setting swappiness to 20 changes that behavior. Found no solution yet, hence just a comment to show a different culprit could be the cause. – Izzy Oct 27 '18 at 12:54
4

Thanks to Doug for the solution to the problem!

I'd probably see if .config, .cache or .local are involved. So for example rename .config to .config.bak & log out/in or restart & see if any different. If not then try the same with .cache, then .local. If the situation improves then look at what's in the causing folder, ect. - doug

To fix it, I renamed the .config folder (located in the home folder, press ctrl+h to show it) to .config.bak, and rebooted. Once back in my session, the problem was gone. After that it was just a matter of finding which folder (or file) within the .config.bak was causing the problem. In the end, it turned out that the "pulse" folder caused the problem. So I left it out and rebooted, all was fine again.

This simple command would have fixed the issue:

rm -rf ~/.config/pulse

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.