I followed this guide to get a 1TB Internal disk partitioned and mounted at boot. I then reboot the PC and can see that the partition is created and and is mounted but doesn't show under 'Files'. If i type in sudo mount i can see this error: /dev/mapper/ubuntu--vg-root on / type ext4 (rw,errors=remount-ro)

So instead of following the guide to partition and mount the drive, I nuked the diskand then used GParted and the disks GUI.

If i then mounted the Partition manually by clicking on the 'Play'button the disks shows under Files.

Then i rebooted and it didn't auto mount.

I then manually set the automount at boot options from the disks GUI:

enter image description here

and rebooted but still never showed underneath files. I then used this command incase it was a permissions issue - sudo chown administrator: /dev/sdb1

rebooted and never worked.

I read on another forum that it was the "nosuid,nodev,nofail" options that were making it fail and that I should try replacing them with just "defaults". This hasn't worked either.

  • zanna - sorry i do have one more question if you dont mind? I didnt issue sudo mkdir /media/cctvstorage but its appeared in the list when i issue sudo df does this mean that when i entered it in the Mount Option GUI it was automatically created or is there no chance that would happen? – dunk2710 Aug 4 '16 at 11:46
  • Oh yes, the GUI dialogue can create it in that case... I just edit /etc/fstab myself. I'll edit my answer :) – Zanna Aug 4 '16 at 12:12

Nautilus will list devices nicely if you put their mount points in /media, but not in /mnt You can call the mount point anything you like, for example /media/my-drive can be set as your mount point in the GUI dialog and this mount point will be created for the device you specify

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.