15

How can I get the Super-D key binding in Xfce desktop? The Start+d is not working and invoking the Whisker menu but not showing the desktop. I tried changing, in the shortcuts, from Ctrl+alt+D to Start+D but that still doesn't work.

This works well in Cinnamon when the Super key is pressed, the menu appears, and for Start+d it just works like in Windows.

What could be the reason, if it works in Cinnamon, it couldn't also work in Xfce?

1
  • Can you please explain how you tried changing the shortcuts? Aug 15, 2016 at 17:40

5 Answers 5

11

You can change the shortcuts that handle the window manager by opening Window Manager from Settings > Window Manager, Keyboard tab.

  • Scroll down until you see Show desktop, (default Ctrl+Alt+D)
  • Click to select the row, and press Edit Window Manager
  • Press the desired keyboard keys combination on Window Manager Action Shortcut popup window (Super+D in your case).
    Window Manager Action Shortcut
  • Click Close.

This way Show desktop will be triggered by Super+D.

1
  • 3
    This doesn't work if you have the Super key bound to open the whisker menu, it seems
    – Clément
    Mar 19, 2019 at 17:38
4

TL;DR Just take a look at the pictures below.

For cute sloths like myself, here goes a much longer explanation. It's 2021 now and I've just encountered this very same issue. I've tried all the variants suggested here in all the answers and comments posted here before mine and nothing helped me (including editing the XML config file and restarting X and PC after that). But I've noticed one thing in the user12458's answer. It's called xfconf. So I went to https://docs.xfce.org/ (which is hard not to notice on Google's search result page) and I saw these three things there:

  • Configuration Storage System (xfconf) – D-Bus-based configuration storage system
  • Settings Manager (xfce4-settings) – The Settings daemon which persists many Xfce settings
  • Settings Editor – Editor that allows to modify all the various setting channels (xfce4-settings-editor)

You can open Settings Editor by typing xfce4-settings-editor in a terminal or as simple as it's shown on the picture below (it's the last one on the list): enter image description here

To add Super-D shortcut for the Xfce window manager, you need to choose xfce4-keyboard-shortcut channel in the left pane, then scroll down the right pane till you see the xfwm4 property and the custom property below it. Left-click on any item below custom and then click New button in the bottom part of the Settings Editor window. Take a look at another picture here: enter image description here

In the Property box append <Super>d to the string /xfwm4/custom/ that will be already there. Choose String for the Type box and write (or copy-paste from here) show_desktop_key to the Value box. Press Save button. The property editing dialog box should disappear now and your shortcut should be activated immediately after.

1
  • Thanks man, that really helped! :) Nov 23, 2022 at 20:44
3

I've had the same problem in Linux Mint 18 Xfce.

I've solved it with the solution in the answers of this link: http://www.linuxquestions.org/questions/linux-software-2/how-to-show-desktop-in-xfce4-601161-print/

A script using the command «wmctrl -k on» and «wmctrl -k off»

#!/bin/sh
if xprop -root  _NET_SHOWING_DESKTOP|egrep '= 1' ; then
      wmctrl -k off ;
    else
      wmctrl -k on ;
    fi

You can create a shortcut to the script in the keyboard settings.

4
  • 1
    Didn't it conflict with Whisker menu? This happens if you have <Super> to trigger the whisker menu. Aug 20, 2016 at 15:10
  • That's not a conflict for me if I have enough time <super>pulsed. So I pulse first <Super> and then <D> and I have no problem. In fact, I have more shortcuts with <super> + <letter>. Also, if you want, you can delete de shortcut to Whisker menu in the keyboard settings. Aug 21, 2016 at 8:17
  • Can that time be adjusted? Aug 21, 2016 at 9:05
  • That the only solution worked from me xubuntu I add that script to new file sudo nano /usr/local/sbin/showdesktop and sudo chmod +x showdesktop Assatinate the shortcut from xfce setting / keyboard application shortcut menu
    – Salem F
    Jul 23, 2018 at 18:05
0

To enable do this:

  • Go to the folder ~/.config/xfce4/xfconf/xfce-perchannel-xml/ (notice, this is a hidden folder, so, if you use Thunar, press Ctrl+H to see hidden folders and files)

  • Open the file xfce4-keyboard-shortcuts.xml with a text editor (if you double-click, it will open in a browser)

  • Add the following line:

    <property name="&lt;Super&gt;d" type="string" value="show_desktop_key"/>
    

In my case I have it in the second subsection, <property name="xfwm4" type="empty">, but it might work in the first one, <property name="commands" type="empty">.

8
  • Not working for me! Aug 4, 2016 at 15:30
  • Then try the above in the same file but in any of these folders (requires sudo power): /etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/ and /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/
    – user308164
    Aug 5, 2016 at 12:16
  • Not working still! Do I have to place it in defaults property? or just directly under xfmw4? I also tried logging out and testing! but still didn't work Aug 5, 2016 at 16:26
  • Strange... have you tried modifying through the Settings Menu? Open the Settings (xfce4-settings-manager in the terminal), select Window Manager, then select Keyboard tab, and scroll down until you see "Show Desktop". Change that one using your key option.
    – user308164
    Aug 5, 2016 at 16:41
  • Yes, but that didn't work. Aug 5, 2016 at 16:45
0

I think there is a bug in XFCE. If I go to Settings > Window Manager > Keyboard and assign the shortcut Super + D it works until the next restart. In order for this shortcut to work always, you need to first remove the existing shortcut assignment. So, first hit the button [Clear] to remove the default shortcut and then hit the Super + D combination. Otherwise, the existing shortcut remains "under cover" and interferes.

Also, of course, you may want to clear any other places where the Windows Key (Super) is used, e.g. to show Whisker Menu, because, otherwise every time you hit Super + D it will try to open Whisker Menu. For example, I use other combinations with the Windows Key, like Super + T = launch Terminal, Super + E = launch Thunar (analogy of Super + E on Windows, where it launches Windows Explorer). So, I had to clear the assignment of the Win Key to show Whisker Menu to prevent the menu from always popping up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.