7

Environment:

Ubuntu 16.04 LTS. The machine uses Intel iris Pro Graphics 580 (Skylake GT4e) graphics processor.

Vulkan: 1.0.21.1

The problem, I installed the Vulkan 1.x SDK, and try to run the cube example. The error message I got is:

./cube
vkEnumerateInstanceExtensionProperties failed to find the VK_KHR_surface extension.

Do you have a compatible Vulkan installable client driver (ICD) installed?
Please look at the Getting Started guide for additional information.

After I installed mesa-util I had following error message:

FINISHME: Get correct values for VkPhysicalDeviceLimits
vulkan: No DRI3 support
Could not find a graphics and a present queue

Solutions I tried:

  1. https://gist.github.com/SaschaWillems/47be6970a3e99a3d30e1 (I used the Mesa 12.01 instead of Mesa master but I think 12.01 is good enough.)

  2. https://launchpad.net/~canonical-x/+archive/ubuntu/vulkan Still unable to run the cube example after the package is installed.

Any idea about how to get vulkan runs on Intel GPU?

5

I ran in to the same issue, recently. After following the two steps you mentioned, this last step allowed me to run the cube demo, although I have no idea if it has any power or performance repercussions.

  • Version: Ubuntu 16.04 LTS
  • Graphics card: Intel(R) HD Graphics 520 (Skylake GT2) (system76 lemur)

According to the Vulkan Setup tutorial, DRI3 stands for 'Direct Rendering Infrastructure 3; a Linux X-Windows extension for direct rendering'

I was able to enable it by following this ask and adding the following lines to /etc/X11/xorg.conf (the file didn't exist on my machine but I added it without issue)

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "SwapBuffersWait" "0"
    Option      "DRI" "3"
EndSection

Then restart your display manager with sudo service lightdm restart (or similar if you changed it) and you should be able to run the demos!

| improve this answer | |
  • That fixed my problem, I am able to run the cube example now, thanks for your help :) – r0ng Aug 7 '16 at 23:57
  • Not sure this change or the update I installed this morning after logged out of ubuntu, I was unable to log in back. Every time I tried to log in, the screen just blink a second then the OS asked me to input usrname/pw again. I tried to use ctrl + alt + F3 to log in shell. Still failed. I have to reinstall the ubuntu again and the development environment. I give up using linux and installed win10 for vulkan. – r0ng Aug 8 '16 at 5:19
2

I didn't need to change xorg.conf to get Intel Vulkan drivers running on Ubuntu 16.04. I just used the padoka PPA and followed these steps:

The padoka PPA (linked in Sascha Willems's answer) worked for me as well, on Ubuntu 16.04.

After adding the PPA to apt, I did the following:

  1. sudo apt upgrade libglapi-mesa libgl1-mesa-dri vulkan-utils
  2. For some reason I had to create an extra symlink for the intel driver:
    sudo ln -s /usr/lib/x86_64-linux-gnu/mesa/libvulkan_intel.so /usr/lib/x86_64-linux-gnu/libvulkan_intel.so
| improve this answer | |
  • 1
    It would be preferable if you could at least sum up the most important stuff from your link directly in the question. – Byte Commander Nov 24 '16 at 23:00
  • @ByteCommander Done. – wjandrea Nov 25 '16 at 1:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.