I upgraded my old machine, a Fujitsu-Siemens Amilo PI 1505, to 11.10 using the alternate DVD ISO. Wireless networking was working before the upgrade. Wireless networking worked during the upgrade. Wireless networking is no longer working after upgrade. It is not available even before logging in.

(Wired connection still works thankfully, but the wire isn't long enough to reach downstairs on top of the TV where the old laptop normally delights us with DVDs, Vimeo shorts or reruns of Big Buck Bunny :)

On a related note, S-Video stopped working when I upgraded to Natty. This was caused by a kernel regression, so back then I installed a new kernel using an arcane means that I don't remember right now.

Symptoms: When I click on the networking indicator none of the options relating to wireless are present. If I click on "Edit connections..." and select the "Wireless" tab, the old wireless connection is still present.

Attempted solution 1: I opened Additional Drivers to check if I needed a proprietary drivers. It is completely empty. (Is that normal?)

Attempted solution 2: Based on this post I edited /etc/NetworkManager/NetworkManager.conf and changed [ifupdown] managed=false to [ifupdown] managed=true. This has made no difference.

Attempted solution 3: Disabled IPv6 per this suggestion. No difference.

What else can I do?

These results generated after attempted solution 2:

Results of lspci -nvn | grep -i net:

05:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
    Subsystem: Intel Corporation PRO/Wireless 3945ABG Network Connection [8086:1001]
06:05.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)

Results of nm-tool:

NetworkManager Tool

State: connected (global)

- Device: eth0  [Wired connection 1] -------------------------------------------
  Type:              Wired
  Driver:            8139too
  State:             connected
  Default:           yes
  HW Address:        --:--:--:--:--:--

    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Prefix:          24 (


Results of iwconfig:

lo        no wireless extensions.

eth0      no wireless extensions.

Results of iwconfig:

lo        no wireless extensions.

eth0      no wireless extensions.

Results of rfkill list all:


Results of sudo iwlist scan:

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

Results of lsmod | grep iwl:


Contents of /etc/NetworkManager/NetworkManager.conf:



Results of sudo modprobe iwl3945:

FATAL: Could not load /lib/modules/3.0.1-030001-generic/modules.dep: No such file or directory

Results of sudo lshw -class network:

  *-network UNCLAIMED     
       description: Network controller
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:f7000000-f7000fff
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 5
       bus info: pci@0000:06:05.0
       logical name: eth0
       version: 10
       serial: 00:03:0d:4b:52:20
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip= latency=32 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
       resources: irq:16 ioport:2000(size=256) memory:b0300c00-b0300cff

Results of uname -a:

Linux ceciliapayne 3.0.1-030001-generic #201108060905 SMP Sat Aug 6 10:43:25 UTC 2011 i686 i686 i386 GNU/Linux
  • 1
    what's the result of sudo lshw -class network – fossfreedom Nov 19 '11 at 15:00
  • 1
    have you tried sudo modprobe iwl3945 ? – sagarchalise Nov 19 '11 at 15:01
  • 1
    I've never used that mainline ppa, so you may need someone with more experience to remove that (don't know the package name to remove), but apt-get install linux-image will put the default oneiric one back. CAUTION DRAGONS if you remove the only working kernel you could be left with a non bootable system, be careful. – Caesium Nov 19 '11 at 15:15
  • 1
    Unless you have a good reason to, I'd stick with linux-image from oneiric and not worry about tracking mainline, to be honest :) – Caesium Nov 19 '11 at 15:16
  • 1
    You may find it's already installed and you just have to select it in grub at boot time. Hold shift to see the menu if I remember rightly – Caesium Nov 19 '11 at 15:21

sudo modprobe iwl3945 revealed a kernel-level error with an odd kernel number. I rediscovered that I had installed a different kernel prior to upgrading. It was newer than the 11.10 kernel and therefore continued to get used, and created havoc.


  • I ran sudo apt-get install linux-image
  • Rebooted
  • Held shift to force the grub menu to appear
  • Chose the correct kernel
  • Said thank you
  • Hi, I'm on Ubuntu 14.04 and have the same issue but sudo modprobe iwl3945 outputs nothing. I had upgraded to a new kernel before and switched it back to the previous one, but the issue hasn't gone yet. Do you have any idea after 3 years, btw? – Ehsan M. Kermani Jun 16 '15 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.