4

Anyone has a solution to this?

On initial install, my headset wasn't identified/found at all. After adding the missing middleware and setting AutoEnable=true in /etc/bluetooth/main.conf, the headset was identified and I was able to use it once. But the very next day I tried to reconnect, and it doesn't work any longer. The device connects successfully, I can hear a notification in the headset, and them it disconnects shortly afterwards(3-5 seconds).

What should I try next?

2

Go into bluetoothctl and set your device to trust

# bluetoothctl
# devices
    Device XX:XX:XX:XX:XX:XX 
# trust XX:XX:XX:XX:XX:XX

Then I rebooted and the device worked fine. This was probably the 15th fix I tried for the numerous issues connecting my bluetooth headset so hopefully this works!

0

For me, using Blueman helped. You can install it with sudo apt install blueman.

  • 2
    You might be able to improve this answer with providing the steps needed in more detail and maybe even adding screen-shots of different parts to make it a rock solid answer. – Videonauth Nov 23 '16 at 10:29
  • @Videonauth, thank You for Your suggestion. I may try doing it in my spare time. – kcpr Jan 26 '17 at 13:14
  • @Videonauth I had similar question about details, but on the other hand tried to install. After installation, restarted my Dell Laptop and problem stopped, I think you may try this. (Also note that my OS is Ubuntu 18) – Giorgi Jambazishvili Jun 9 '18 at 10:40
0

What helped me in the end is trying different approaches from https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1574324, including a custom PPA from Luke.

0

had the following issues on ubuntu 18.04 with dell xps 13 9370

  • bluetooth headset connects and then disconnects in a couple of seconds
  • when trying to pair with blueman "Device added successfully, but failed to connect"
  • and I would never have the option to select my headphones in the sound settings.

did the following steps to fix it:

  • upgrade blueman

    sudo apt upgrade blueman

  • unpair headphones

go into Ubuntu Settings > Bluetooth click on my bluetooth headphones > remove

  • pair headphones with blueman

put my headphones into pairing mode open blueman in sys tray and click on setup new device, select headphones, go through steps (put "headset" as device type)

0

I am using Linux Mint 19, my headphone is a Sony MDR-XB650BT and my laptop is a Dell Inspiron 7000. I have been fighting all day to make this phone work with my laptop and no solution ever worked.

I was able to pair but seconds after the phone disconnected. I found the solution here: https://unix.stackexchange.com/questions/258074/error-when-trying-to-connect-to-bluetooth-speaker-org-bluez-error-failed

Summarizing: Install pulseaudio-module-bluetooth!

You can find more details in the answer over here.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.