0

Thanks for previous questions about automatic installation, but I am running into an issue doing an automatic install without getting a swap partition.

Here is my ks.cfg:

#Generated by Kickstart Configurator
#platform=AMD64 or Intel EM64T

#System language
lang en_US
#Language modules to install
langsupport en_US
#System keyboard
keyboard us
#System mouse
mouse
#System timezone
timezone --utc UTC
#Root password
rootpw --disabled
#Initial user
user deleteme [...]
#Reboot after installation
reboot
#Use text mode install
text
#Install OS instead of upgrade
install
#Use CDROM installation media
cdrom
#System bootloader configuration
bootloader --location=mbr 
#Clear the Master Boot Record
zerombr yes
#Partition clearing information
clearpart --all --initlabel 
#Disk partitioning information
part / --fstype ext4 --size 1 --grow --asprimary 
part swap --size 100
#System authorization infomation
auth  --useshadow  --enablemd5 
#Firewall configuration
firewall --disabled 
#Do not configure the X Window System
skipx
#Install these packages
%packages
openssh-server
# After system is installed, remove the apt.conf file with debproxy defined.
%post
rm -rf /etc/apt/apt.conf
%end

Commenting out the part swap --size 100 line causes the installer to complain and create a prompt. I've tried setting the size to 0 but that causes another issue that causes many prompts. Is there a way to get rid of swap and not get silly prompts?

  • Maybe set swap to 1? – grooveplex Aug 3 '16 at 18:52
  • Maybe you should create separate partitions for boot, swap and root (in that order). You are using --grow for / and my guess is that / is filling up disk and there is not room for swap. My hint would be part part /boot --fstype ext4 --size 1024 --asprimary for boot, part swap --size 100 --asprimary for swap (is 100MB enough for swap ?) and after that part / --fstype ext4 --size 1 --grow --asprimary for root which will fill up remaining space. – iuuuuan Aug 4 '16 at 5:00
  • part swap --size 100 "works" in the sense that it doesn't produce an error, but I'm still left with swap space I'd rather not have. A coworker suggested removing it in %post which I'll try today. – chicks Aug 4 '16 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.