1

I have had our two Canon MF8580Cdw printers work perfectly with Ubuntu until I upgraded to Ubuntu 16.04. Now we only get a printout with the following:

**** Unable to open the initial device, quitting.

I am using the latest version of the Canon drivers, the same I have used earlier.

Our HP printers work without problems, but it would be great to get the Canons back working again.

  • Have you tried deleting the Canon printer, and then adding it back? How about reinstalling the Canon printer driver (where did you get the drivers before?). – heynnema Aug 3 '16 at 19:50
  • Same issue here, Canon LBP5030w :( – Oscar Mederos Aug 7 '16 at 18:10
  • I have tried to add and remove it many times. On my 15.10 machines it works flawlessly, on 16.04 not. Other printers like my HP 4500 work fine on both 15.10 and 16.04. Something happened in 16.04 that broke some Canon printers. Good to know it's not only me though! – Christian Aug 7 '16 at 19:39
1

I found the answer: I had to install Skype to get the printer to work! The only difference between the laptop that could print and the one that didn't was Skype. Seems like this 64 bit Canon driver needs some 32 bit or QT stuff to work. Canon should add whatever it is to their packages. As soon as Skype, which is a 32 bit application) was installed with it's enormous amount of dependencies the printer works again. I am not knowledgeable enough to be able to find out exactly which part of Skype's dependencies makes the printer work, but maybe someone else can?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.