2

I'm trying to do a BLE scan and ultimately use gatttool to debug a BLE device on Ubuntu 16.04 LTS.

I'm virtualizing the Ubuntu image using VMware Pro 8.1.1 on a 2014 retina MacBook Pro. I can confirm that the Bluetooth driver works and supports BLE on the Mac, but I'm having trouble getting a BLE scan to work on Ubuntu.

Output from sudo hcitool lescan:

Set scan parameters failed: Input/output error

I logged more info from sudo hcidump -X while trying the BLE scan:

< HCI Command: LE Set Scan Parameters (0x08|0x000b) plen 7
    type 0x01 (active)
    interval 10.000ms window 10.000ms
    own address: 0x00 (Public) policy: All
> HCI Event: Command Complete (0x0e) plen 4
    LE Set Scan Parameters (0x08|0x000b) ncmd 255
    status 0x01
    Error: Unknown HCI Command

This leads me to believe that the driver does not support BLE. I've tried both Ubuntu 16.04 LTS and 15.10. I've installed the VMware drivers in both cases.

Has anyone gotten BLE working on Ubuntu in VMware before?

  • Seems VMWare Workstation doesn't work either in Windows. Does VMWare have a plan to support it? – yushulx May 8 at 8:29
3

In case anyone else is facing this, VMWare contacted me and said that they don't support BLE in Linux guests with a Mac host. If you have a Mac host, you can install the Bootcamp drivers and run Windows, but Linux users are out of luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.