After very painful update to 16.04 I have a problem with wireless headset Sony DR-BTN200. It doesn't produce any sound, and the media freezes.

For example, I open some video on youtube. It plays on laptop's speakers, I can hear the sound. Once I connect headset, the sound stops and video just pauses (however, pause button of youtube player is not pressed). The same thing is when I try to play some mp3 or watch any movie. The only exception is Spotify - it shows visually that track is playing, but there's no sound and also Spotify displays a notification that track cannot be played.

Once I disconnect headset, the video or audio continues playing from the place it paused. If I try to first connect headset and then open a video, it doesn't start (but is loading), and starts right after I disconnect headset.

I tried to press buttons on my headset. I can tell that youtube reacts on play button - it shows buttons, just like if I moved the mouse or pressed any button. But there's no any reaction, video still stays paused.

Headphones are connected as headset, profile is Hihg fidelity playback (A2DP sink). The problem appeared right after update to 16.04, it worked perfectly with 14.10.


3 Answers 3


I have a Divoom Voombox-outdoor, and I had similar issues. Everything playing would stop/freeze and it would not work after I connected it.

After I have searched on the internet, I have found a procedure to do when connecting and removing it. On a initial connection (and unique if the procedures after this one are always made):

  • connect the bluetooth speaker/headset (may be using blueman or bluetoothctl or another equivalent);
  • with pavucontrol or blueman (or equivalent), turn off the bluetooth device;
  • disconnect the device.

Then connecting it (this time to work):

  • connect the bluetooth speaker/headset (may be using blueman or bluetoothctl or another equivalent);
  • with pavucontrol or blueman (or equivalent), choose the option High Fidelity Playback (A2DP Sink).

It would need to turn off the internal sound to make all programs use the bluetooth sink.

When disconnecting it:

  • with pavucontrol or blueman (or equivalent), turn off the sound device;
  • disconnect the bluetooth speaker/headset (may be using blueman or bluetoothctl or another equivalent).

The three procedures can be done using only blueman, as on it there are options to change the audio configuration.

What may happen is forgetting to turn the device off on pavucontrol before disconnecting, which will require to do again the first procedure. This is curious, because the speaker, sometimes, turn off when that is done, as if its firmware had crashed (this is still better than Windows 10, which asks to reboot).

I use Xubuntu 16.04, so there may be differences between the programs used, but the idea is to always turn off the sink of the device from pulseaudio before disconnecting it.

  • Thank you for this workaround. I haven't awarded the bounty as I'm after launchpad bug report and root cause.
    – Tim Abell
    May 19, 2017 at 19:27

After changing Audio Profile to High Fidelity Playback (A2DP Sink), that works very well. I am using ubuntu 18.04 and blueman. My phone is Sony WH1000-XM3. The setup steps as followed:

  1. remove bluez if it is installed: sudo apt-get remove --auto-remove bluez
  2. install blueman: sudo apt-get install blueman
  3. enable and start bluetooth service: modprobe btusb; sudo systemctl enable bluetooth.service; sudo systemctl start bluetooth.service
  4. check it and unblock: sudo systemctl status bluetooth; rfkill unblock bluetooth
  5. reboot
  6. turn on the headset -> click the green bluetooth icon on top-right corner of the screen -> choose Devices
  7. Click Search and right click on your device, choose Pair.
  8. Right click on your device again and choose Headset if it is not connected.
  9. Right click on your device -> hover over Audio Profile -> Click High Fidelity Playback (A2DP Sink)

Now, test with a youtube video.

Note: You may need to click Headset a few times to connect and disconnect until it works.


I had the issue with Ubuntu 18.04.

I could fix it as follows.

First do

dmesg | grep -i bluetooth 

to check if you have firmware Bluetooth issues.

If you actually have an issue, for example this:

bluetooth hci1: Direct firmware load for brcm/BCM20702A1-0b05-17cb.hcd failed with error -2

then you can download the specific version at https://github.com/winterheart/broadcom-bt-firmware/tree/master/brcm (the full name must match)

THen copy it to /lib/firmware/brcm and reboot. Since I made this update, Bluetotoh works fine with Videos and everything!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .