6

I have got the most strange problem, I downloaded 4 images yesterday, then cut and paste them using Nautilus into a sub-folder of my Documents area. I then closed Nautilus and went on with my normal business.

However later on I needed to send the images to someone so I went into the folder with the images using Nautilus, but they weren't there! And this is where it gets even stranger, the images show up, though not their thumbnails, when I use Firefox's file chooser for instance, or another program's file chooser, in fact if I open the Image Viewer and then use its file chooser to find them I can open and view them perfectly fine.

The other odd thing is that Nautilus half knows they are there, because my first reaction was to think that my computer just ate them somehow, so I redownloaded them, and pasted them into the folder where the previous ones should have been. Nautilus asked me if I wanted to replace the old with the new and it even showed me the correct thumbnails this time!

I am also able to see that the files are present in Terminal using commands such as ls and tree, I can also cat the contents so the files are readable and everything.

Here is the stat output for one of them:

 stat DSCF2365.jpg
  File: 'DSCF2365.jpg'
  Size: 2213598     Blocks: 4328       IO Block: 4096   regular file
Device: fc00h/64512d    Inode: 29623172    Links: 1
Access: (0664/-rw-rw-r--)  Uid: ( 1000/  totoro)   Gid: ( 1000/  totoro)
Access: 2016-08-02 23:39:15.651962645 +0100
Modify: 2016-08-02 22:51:26.613739542 +0100
Change: 2016-08-02 23:12:04.540134139 +0100
 Birth: -

It was suggested to me that this could be because of a filesystem error, so I ran fsck on boot and this was the output in syslog:

Aug  3 10:54:45 <Computer-Name> kernel: [    0.000000] Command line: BOOT_IMAGE=/vmlinuz-4.4.0-31-generic.efi.signed root=/dev/mapper/ubuntu--gnome--vg-root ro noprompt fsck.mode=force
Aug  3 10:54:45 <Computer-Name> systemd-fsck[2176]: fsck.fat 3.0.28 (2015-05-16)
Aug  3 10:54:45 <Computer-Name> systemd-fsck[2176]: /dev/sda1: 28 files, 3120/130812 clusters
Aug  3 10:54:45 <Computer-Name> systemd-fsck[2191]: /dev/sda2: 301/62496 files (22.6% non-contiguous), 129379/249856 blocks
Aug  3 10:54:45 <Computer-Name> kernel: [    0.000000] Kernel command line: BOOT_IMAGE=/vmlinuz-4.4.0-31-generic.efi.signed root=/dev/mapper/ubuntu--gnome--vg-root ro noprompt fsck.mode=force
Aug  3 10:55:00 <Computer-Name> /usr/lib/gdm3/gdm-x-session[3200]: Kernel command line: BOOT_IMAGE=/vmlinuz-4.4.0-31-generic.efi.signed root=/dev/mapper/ubuntu--gnome--vg-root ro noprompt fsck.mode=force
Aug  3 10:55:31 <Computer-Name> /usr/lib/gdm3/gdm-x-session[3341]: Kernel command line: BOOT_IMAGE=/vmlinuz-4.4.0-31-generic.efi.signed root=/dev/mapper/ubuntu--gnome--vg-root ro noprompt fsck.mode=force

I will soon do the same checks from a LiveUSB, when I have done that I will update this question with the information on how that went. If this is useful to anyone the output of lsblk is:

NAME                         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda                            8:0    0 465.8G  0 disk
├─sda1                         8:1    0   512M  0 part /boot/efi
├─sda2                         8:2    0   244M  0 part /boot
└─sda3                         8:3    0   465G  0 part
  ├─ubuntu--gnome--vg-root   252:0    0 461.2G  0 lvm  /
  └─ubuntu--gnome--vg-swap_1 252:1    0   3.9G  0 lvm  [SWAP]
sr0                           11:0    1  1024M  0 rom

So I am using LVM. I am running Ubuntu GNOME 16.04 with GNOME 3.20. What could the problem be and what shall I do about it? The place to which I downloaded the second batch of the same files still shows them (my Downloads folder).

Information Update:

I have now tried installing nemo, and the issue is also present there.

And there is something even more interesting that I have discovered, if I search for the file names using nautilus and nemo, they do come up in the search results, their thumbnails show correctly, and I am able to open them!

The output of blkid is:

/dev/sda1: UUID="9936-E7FF" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="8054dcbf-83e1-4d42-bd5c-7a7ec2b5b563"
/dev/sda2: UUID="a1ee7705-4528-434a-8aca-54486d48093d" TYPE="ext2" PARTUUID="56930149-d506-4773-9b31-b9ab1fa3aed8"
/dev/sda3: UUID="4Fa3uc-So0F-4d6c-ePh9-Eb09-JMl1-30k45r" TYPE="LVM2_member" PARTUUID="3816306f-068b-4385-b2a9-a67e320d7b4a"
/dev/mapper/ubuntu--gnome--vg-root: UUID="925ad182-e013-4b66-8b0c-18e549a28f82" TYPE="ext4"
/dev/mapper/ubuntu--gnome--vg-swap_1: UUID="97995176-acae-4d9a-bb88-08adefd556df" TYPE="swap"

If I use the mv command to rename the file, it still does not show.

I have now looked again and the files have reappeared along with a lot of other files which were missing from that folder! I hope them reappearing hasn't made any others disappear, is there any way I can check? What could be causing this?

closed as off-topic by user364819, muru, Martin Schröder, Charles Green, user68186 Feb 8 '18 at 14:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Community, muru, Martin Schröder, Charles Green, user68186
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Is the problem reproducible? Is it manifesting for other files? What happens if you clone the files on the same path to a new filename? Do they then show on Nautilus? Have you tried installing Nemo to see what that shows? What filesystem are you using? – DanglingPointer Aug 3 '16 at 10:38
  • @DanglingPointer: I don't know, I expect so, I hope no more files on my system have gone missing, but I'm sure that I had more pictures in that folder than are showing there now... The files still haven't turned up, I will keep an eye out to see if it happens with any more new files. I will try what you said and update my question. I have tried Nemo and updated my question. – user364819 Aug 3 '16 at 10:48
  • 1
    Whatever the gist of a problem is, report a bug against nautilus. Given that files shows up with ls, everything is fine with file system either, it's just a bug in a file manager. – Hi-Angel Aug 3 '16 at 12:11
  • 1
    @Hi-Angel: But the problem is also present in the Nemo file manager... So isn't it going to be something more central than that? – user364819 Aug 3 '16 at 12:27
  • 2
    @ParanoidPanda I'd rather guess they're using the same library of something, and that library have a bug. Unless you have an idea what library could that be, report a bug against nautilus, devs would figure it out. – Hi-Angel Aug 3 '16 at 12:29
3

Had the issue of files/folders not appearing in File Manager, but being listed in terminal. Solved it by going in File Manager > View > Reload (Ctrl+R).

3

I suggest you open a terminal, cd to the directory in question, and run "ls -la". That is the least likely to lie to you. You will see all files, and their permissions.

A GUI file manager like nautilus or such is a few steps away from the full, accurate truth about what is there and what are its properties. That file manger may have "features" or "simplifying enhancements" that prevent you from seeing everything that is there.

There may be a bug, but I'm betting on the "simplifying enhancement" aspect. I've been using Nautilus for 10 years and often I can't find anything anymore. They have made it so "helpful" it is almost useless. You can't even launch a terminal out of it anymore.

If your terminals lack beauty, consider installing "terminology" from the enlightenment project. There's some eye candy. I cant quite believe it.

0

I’ve just been having this problem in Nemo and a workaround is to change the view. I usually use list view so I changed to icon view and back. This forced a refresh which the actual Refresh command didn’t.