I have upgraded to Ubuntu 16.04 and boot is slow. I paste only parts from dmesg that are quite slow.

[    0.204212] PCI: CLS 64 bytes, default 64
[    0.204244] Trying to unpack rootfs image as initramfs...
[    0.580208] Freeing initrd memory: 34716K (ffff880033c22000 - ffff880035e09000)
[    0.580233] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)

[    0.708039] ata1: SATA max UDMA/133 abar m2048@0xf7216000 port 0xf7216100 irq 30
[    0.708040] ata2: DUMMY
[    0.708041] ata3: DUMMY
[    0.708042] ata4: DUMMY
[    0.708044] ata5: SATA max UDMA/133 abar m2048@0xf7216000 port 0xf7216300 irq 30
[    0.713054] r8169 0000:03:00.0 eth0: RTL8168g/8111g at 0xffffc9000073e000, f8:bc:12:6a:b1:27, XID 0c000800 IRQ 31
[    0.713057] r8169 0000:03:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[    0.916133] usb 1-1: new high-speed USB device number 2 using ehci-pci
[    0.932126] usb 3-1: new full-speed USB device number 2 using xhci_hcd
[    0.932135] usb 2-1: new high-speed USB device number 2 using ehci-pci
[    1.024132] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)

[    1.731849] usbcore: registered new interface driver usb-storage
[    1.732726] usbcore: registered new interface driver uas
[    1.745077] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[    2.527620] random: nonblocking pool is initialized
[    2.580169] clocksource: Switched to clocksource tsc

and the last part

[    7.064802] systemd[1]: Started Apply Kernel Variables.
[    7.120884] systemd[1]: Started Set console keymap.
[    7.182860] systemd[1]: Started Journal Service.
[    9.806764] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[    9.993932] systemd-journald[855]: Received request to flush runtime journal from PID 1
[   10.764016] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   11.581881] dcdbas dcdbas: Dell Systems Management Base Driver (version 5.6.0-3.2)
[   11.687512] AVX2 version of gcm_enc/dec engaged.
[   11.687514] AES CTR mode by8 optimization enabled
[   11.693854] [drm] Initialized drm 1.1.0 20060810
[   12.128087] snd_hda_intel 0000:01:00.1: Disabling MSI
[   12.128091] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[   12.219941] snd_hda_codec_realtek hdaudioC0D2: autoconfig for ALC662 rev3: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[   12.219944] snd_hda_codec_realtek hdaudioC0D2:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   12.219946] snd_hda_codec_realtek hdaudioC0D2:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[   12.219946] snd_hda_codec_realtek hdaudioC0D2:    mono: mono_out=0x0
[   12.219947] snd_hda_codec_realtek hdaudioC0D2:    inputs:
[   12.219949] snd_hda_codec_realtek hdaudioC0D2:      Rear Mic=0x19
[   12.219950] snd_hda_codec_realtek hdaudioC0D2:      Front Mic=0x18
[   12.219951] snd_hda_codec_realtek hdaudioC0D2:      Line=0x1a
[   12.229089] input: HDA Intel PCH Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8
[   12.229127] input: HDA Intel PCH Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
[   12.229160] input: HDA Intel PCH Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
[   12.229191] input: HDA Intel PCH Line Out as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
[   12.229223] input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
[   12.515231] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input13
[   12.515268] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input14
[   14.368589] nvidia: module license 'NVIDIA' taints kernel.
[   14.368592] Disabling lock debugging due to kernel taint
[   14.371983] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[   14.375548] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[   14.375613] nvidia-nvlink: Nvlink Core is being initialized, major device number 246
[   14.375710] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 0
[   14.375713] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  361.42  Tue Mar 22 18:10:58 PDT 2016
[   14.770921] Adding 4142076k swap on /dev/sda5.  Priority:-1 extents:1 across:4142076k FS
[   14.920390] intel_rapl: Found RAPL domain package
[   14.920392] intel_rapl: Found RAPL domain core
[   14.920394] intel_rapl: Found RAPL domain dram
[   14.920396] intel_rapl: RAPL package 0 domain package locked by BIOS
[   14.920398] intel_rapl: RAPL package 0 domain dram locked by BIOS
[   15.039367] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  361.42  Tue Mar 22 17:29:54 PDT 2016
[   15.226610] nvidia-uvm: Loaded the UVM driver in lite mode, major device number 245
[   17.247667] audit: type=1400 audit(1470190982.111:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/ubuntu-core-launcher" pid=2402 comm="apparmor_parser"
[   17.260652] audit: type=1400 audit(1470190982.119:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=2399 comm="apparmor_parser"
[   17.260656] audit: type=1400 audit(1470190982.119:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=2399 comm="apparmor_parser"
[   17.260659] audit: type=1400 audit(1470190982.119:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-helper" pid=2399 comm="apparmor_parser"
[   17.260662] audit: type=1400 audit(1470190982.119:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=2399 comm="apparmor_parser"
[   17.370137] audit: type=1400 audit(1470190982.227:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/mission-control-5" pid=2404 comm="apparmor_parser"
[   17.370142] audit: type=1400 audit(1470190982.227:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/telepathy-*" pid=2404 comm="apparmor_parser"
[   17.370145] audit: type=1400 audit(1470190982.227:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/telepathy-*//pxgsettings" pid=2404 comm="apparmor_parser"
[   17.370148] audit: type=1400 audit(1470190982.227:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/telepathy-*//sanitized_helper" pid=2404 comm="apparmor_parser"
[   17.370151] audit: type=1400 audit(1470190982.227:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/telepathy-ofono" pid=2404 comm="apparmor_parser"
[   21.790450] cgroup: new mount options do not match the existing superblock, will be ignored
[   26.110295] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   26.276323] r8169 0000:03:00.0 eth0: link down
[   26.276342] r8169 0000:03:00.0 eth0: link down
[   26.276385] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   28.613629] r8169 0000:03:00.0 eth0: link up
[   28.613636] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   37.466205] vboxdrv: Found 4 processor cores
[   37.484930] vboxdrv: TSC mode is Invariant, tentative frequency 3192606045 Hz
[   37.484941] vboxdrv: Successfully loaded version 5.0.24_Ubuntu (interface 0x00240000)
[   37.487363] VBoxNetFlt: Successfully started.
[   37.489455] VBoxNetAdp: Successfully started.
[   37.491734] VBoxPciLinuxInit
[   37.493687] vboxpci: IOMMU not found (not registered)
[   40.412102] nvidia-modeset: Allocated GPU:0 (GPU-7c788e0d-eac6-268b-9ef9-38957d72fb15) @ PCI:0000:01:00.0

Here is systemd-analyze blame

18.266s mysql.service
         13.201s NetworkManager-wait-online.service
          9.566s lightdm.service
          8.373s dev-sda1.device
          8.025s apparmor.service
          7.085s grub-common.service
          6.356s ModemManager.service
          6.241s gpu-manager.service
          5.251s snapd.refresh.service
          3.854s accounts-daemon.service
          3.752s networking.service
          3.674s thermald.service
          3.525s apache2.service
          3.305s console-setup.service
          3.261s systemd-tmpfiles-setup.service
          3.243s speech-dispatcher.service
          3.234s console-kit-log-system-start.service
          3.227s rsyslog.service
          2.998s NetworkManager.service
          1.931s systemd-udevd.service
          1.842s colord.service
          1.450s plymouth-start.service
          1.437s polkitd.service
          1.403s systemd-tmpfiles-setup-dev.service
          1.349s systemd-journald.service
          1.295s keyboard-setup.service
  • I think problem is NetworkManager-wait-online.service wanted by network-online.target
    – chejnik
    Aug 3, 2016 at 4:36
  • I have followed that question and I have changed the value from 30 to 10 at ExecStart=/usr/bin/nm-online -s -q --timeout=30 but with no efect.
    – chejnik
    Aug 3, 2016 at 5:05
  • Then change it to 1 instead of 10. That's what I did and for me it has not broken any services.
    – mchid
    Aug 3, 2016 at 5:11

3 Answers 3


My boot time is way longer but if you really want to speed things up and don't care about the splash screen, you can disable the splash screen to make things faster.

You can do this by editing /etc/default/grub. You can make the necessary changes by running the following commands:

sudo sed -i 's/splash/profile/g;s/quiet//g' /etc/default/grub
sudo update-grub

This replaces the kernel flags quiet splash with profile to skip the splash screen.

To revert this change, run the following commands:

sudo sed -i 's/profile/quiet splash/g' /etc/default/grub
sudo update-grub

Additionally, you can disable some unused services if you are not using them. For example, unless you are using a dial up or a modem, you can disable ModemManager:

sudo systemctl disable ModemManager

Also, depending on your needs, you may not need apache2 to start up at boot time.

Running the following command will disable startup of apache2 at boot time:

sudo systemctl disable apache2

and you can start apache2 after you boot using the command:

sudo systemctl start apache2

whenever apache2 is needed.

Finally, run the following command to edit the timeout value for NetworkManager-wait-online.service:

sudo nano /lib/systemd/system/NetworkManager-wait-online.service

Change timeout=30 to timeout=1

Press CTRL + o and then press ENTER to save the file. Press CTRL + x to exit nano.

If this breaks any services, increase the value. If not, enjoy a faster boot time.

  • There is only one second difference.
    – chejnik
    Aug 3, 2016 at 4:28
  • @chejnik I have updated the instructions.
    – mchid
    Aug 3, 2016 at 4:45
  • I have disabled ModemManagar and apache2. I have uninstalled MySql, though I will need it later. 5 second better now. But 12 seconds waiting for NetworkManager!
    – chejnik
    Aug 3, 2016 at 5:03
  • @chejnik I have updated the answer. You should be able to set the timeout to 1 second without any issues. If you have issues, increase the time from there but I don't see any services that depends on the network.
    – mchid
    Aug 3, 2016 at 5:34
  • 1
    @chejnik Sure no problem, here it is: sudo sed -i 's/profile/quiet splash/g' /etc/default/grub and then run sudo update-grub I have included this in the answer.
    – mchid
    Aug 3, 2016 at 5:48

Does your machine boot faster if you leave the Ethernet cable unplugged? If so, the r8169 driver is flawed, and should be replaced with r8168-dkms, installed from Synaptic.

Also, are you booting from a SSD? Sometimes it'll boot too fast... faster than the network has a chance to become ready... and you have to tweek your startup.

Report back.


Fortunately, I have solved this very same problem on my desktop just now, so I am glad to share the solution. Specifically, I am answering the question as to why there is a 4.5 seconds delay between these two lines in your log:

[ 2.580169] clocksource: Switched to clocksource tsc [ 7.064802] systemd[1]: Started Apply Kernel Variables.

The same thing happened to me after I switched my rootfs from Samsung 840 EVO 256GB SSD to Samsung 850 EVO 500GB SSD. At first I thought that the newer and bigger Samsung SSD is slower, but only one seconds' contemplation suggested that this is utter nonsense. So, I remembered what else I have done at the same time, namely: I have removed two other hard drives from the system (to keep the system quiet and use SSD only). Now, one of these hard drives had a swap partition and although I don't use swap (I have plenty of RAM in this desktop) there was a UUID pointer to it in this file:


So, the disk has gone, but a UUID pointer to one of its partitions was still used in your initramfs image on boot! Aha, so that is where those 4.5 seconds are used! To confirm this guess I just deleted the UUID line from the above resume file and also run this command:

$ sudo update-initramfs -u

Then rebooted the system and --- lo and behold --- the boot time is down to 2.1 seconds (it was 2.3 seconds with Samsung 840 EVO and jumped up to almost 7 seconds prior to this fix).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.