1

Okay, after making changes to my ALSA settings (namely, specifying a model rather than leaving it auto), I have things set up so that analog 5.1 surround is able to be properly output to with, say, aplay or speaker-test -- the device that should correspond with it does. However, pulseaudio is still reporting it as "unplugged", which I believe is causing problems. Things that have an over-ride to specifically output through analog does fine, but even if I set it as the default output in /etc/pulse/default.pa, it can't actually be treated as a default for thesystem in general. At best, I can manage this by manually switching over the output in pulseaudio Volume Control for each app, and it still doesn't show as an option in System Settings --> Sound. If it matters, I have ALC889 on-board audio, and I'm using 16.0.4.1 LTS with its default kernel.

2

Finally solved it. I had one speaker jack in a port that was working, but technically wasn't actually the "right port", and because of the way pulseaudio detects line out status, that made it detect the speakers as unplugged.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.