0

Strangely I am unable to install GIMP on my Ubuntu 16.04.

If I do

apt install gimp

Then I get the following error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gimp : Depends: libgegl-0.3-0 (>= 0.3.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried the following command:

aptitude install gimp

It gives me the following output:

The following NEW packages will be installed:
  gimp gimp-data{a} libamd2.4.1{a} libbabl-0.1-0{a} libblas-common{a} libblas3{a} libcamd2.4.1{a} libccolamd2.9.1{a} libcholmod3.0.6{a}
  libgegl-0.3-0{a} libgfortran3{ab} libgimp2.0{a} liblapack3{a} libumfpack5.7.1{a} python-cairo{a} python-gobject-2{a} python-gtk2{a}
0 packages upgraded, 17 newly installed, 0 to remove and 0 not upgraded.
Need to get 19.9 MB of archives. After unpacking 92.3 MB will be used.
The following packages have unmet dependencies:
 libgfortran3 : Depends: gcc-5-base (= 5.3.1-14ubuntu2.1) but 5.4.0-6ubuntu1~16.04.1 is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     gimp [Not Installed]                              
2)     libcholmod3.0.6 [Not Installed]                    
3)     libgegl-0.3-0 [Not Installed]                      
4)     libgfortran3 [Not Installed]                      
5)     liblapack3 [Not Installed]                        
6)     libumfpack5.7.1 [Not Installed]                    

     Leave the following dependencies unresolved:        
7)     gimp-data recommends gimp                          


Accept this solution? [Y/n/q/?]

By default the solution asks me not to install gimp. So I press n. Next I get the following output:

http://pastebin.com/6xjee46F

Naturally I cannot accept this output as it asks me to remove a lot of packages. So I press n. Now I get the following output:

http://pastebin.com/Txjta1Nk

I can't accept this solution as well as it asks me to uninstall a lot of packages. I again press n. Now I get the following output:

http://pastebin.com/A45ZBqWf

I press n. I get the following output:

http://pastebin.com/W5yqfdZG

I press n and I get the following output:

http://pastebin.com/4ULkgSXa

and it goes on...

It may be noted that I am not ready to downgrade my Ubuntu version itself, as mentioned in:

libgfortran3 : Depends: gcc-5-base (= 5.3.1-14ubuntu2.1) but 5.4.0-6ubuntu1~16.04.1 is installed.

The following is my apt update output which shows all the current PPAs

http://pastebin.com/uQxF7SSq

Also I am unable to enable xenial updates repository. It gives me the error for no release file found.

Any ideas how to solve this problem?

10
  • Exactly where can't you enable Xenial updates repository. Do you have your server set to United States in the Software & Updates app? You also have broken packages. Start Synaptic, and try and use Fix Broken Packages in the Edit menu.
    – heynnema
    Aug 2, 2016 at 22:47
  • I am sorry, but I don't have broken packages. From where can you conclude this? No I have set my server as main server, I tried all servers including India, my country.
    – rancho
    Aug 2, 2016 at 22:56
  • This has been a perennial problem for me, xenial updates repository issue...
    – rancho
    Aug 2, 2016 at 22:58
  • You have the GIMP PPA enabled. Does it install correctly if you disable that one? I know it will be GIMP 2.8 and not 2.9, but let's try this first. Aug 2, 2016 at 23:01
  • In Software & Updates, do you show anything on the first tab under "Installable from CD-ROM/DVD"? In the third tab, Updates, do you have the first 3 items checked?
    – heynnema
    Aug 2, 2016 at 23:05

2 Answers 2

1

As I mentioned earlier, the problem is probably with your Xenial Updates repository. Try using another server until you get one that works for you. Cheers, Al

0

I had the exact same issue with a newer version of gimp which requires a libgegl-0.4-0 (>= 0.4.0.16) where I had 0.4.0.12. The upgrade libgegl-0.4-0 required libraw16 but I had libraw19 installed and libraw16 was not available.

This occurred after a dist upgrade and gimp ppa repo I was using for gimp addons was down level and once I found it and corrected it the problem resolved itself.

"deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu cosmic main" should have pointed to "disco"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.