0

This question already has an answer here:

I'm on 32 bit Lubuntu 16.04 and Chromium has the usual Flash version 11.2.9. A bunch of things won't play correctly so I've been trying to find a way to install Pepper Flash for a while and I'm not sure how to proceed.

I have the canonical repo enabled and I've tried installing PPAs in multiple ways--the package is always missing or there's no release file. Almost every online thread about this is from 2014 and I'm very new to Linux and very confused. And now the terminal is also on a loop when I use sudo apt-get update--it keeps trying to update & install ppa:skunk/pepper-flash which has no release file.

I have the latest tarball from Adobe. Could I extract it and manually install the Pepper Flash plugin as root? If so how would I do this? (I found a guide for this for Firefox but it didn't work out because it was majorly outdated.)

Forgive me if I'm missing something obvious, I have a headache. Thanks a bunch for any input.

EDIT: This got flagged as a duplicate but it's not--I was asking how to/if I could install via a tarball as root while the other question did not specify that this method was exactly what they needed info about. It is similar but not a duplicate.

marked as duplicate by Byte Commander, dobey, edwinksl, Anwar, karel Aug 3 '16 at 6:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

Really, you can't. "Pepper flash" is not from Adobe, but from Google. You can't get the tarball for it from Adobe. What you got from Adobe is almost certainly what you already have. The main problem is that you are on 32-bit, and Google no longer builds Chrome for 32-bit, which means they also no longer build the flash plug-in for 32-bit.

You can install the adobe-flashplugin package, but it will also be stuck at version 11.2.999…

0

According to this link here, pepperflash is no longer used. I believe the package you are looking for is adobe-flashplugin. So sudo apt-get install adobe-flashplugin should do it for you. Hope this helps.

  • Thank you, I believe it worked! I did find a version of that command elsewhere in one 2014 article or two but a part of it was different. That was driving me mad. I send cupcakes in gratitude. – user558902 Aug 2 '16 at 21:13
  • No problem, I'm glad that it worked out for you! – Stephen Briles Aug 2 '16 at 22:53