9

When using GTK3 themes on GNOME, GNOME Tweak Tool has an option to enable 'Global Dark Theme'. With Numix GTK theme, it produces this look: Numix with dark theme mode enabled on GNOME

With Unity 7, when you use Unity Tweak Tool to change the theme from Ambiance to Numix, there is no way to enable the dark theme mode. The result looks like this: Numix on Unity 7

Is there a way I can make Numix in Unity 7 look like it does in GNOME when the 'Global Dark Theme' option is checked in GNOME Tweak Tool?

7

You can enable 'Global Dark Theme' mode on Unity 7, the same way it's enabled on Gnome Shell. Just install GNOME Tweak Tool by clicking here:
Install GNOME Tweak Tool

Or run this in Terminal:

sudo apt install gnome-tweak-tool

When it's installed, open Tweak Tool from the Dash and toggle on 'Global Dark Theme' switch as shown below:

GNOME Tweak Tool

From now on you can use the dark mode of themes under Unity 7 the same way you use them on GNOME!😊 If it's not working, just check if the theme implements GNOME's dark theme mode.

Manual Method

GNOME Tweak Tool and most of the options it provides are tailored for Gnome Shell and so may not work as intended on Unity. Coz of this, many users prefer not to install GNOME Tweak Tool and choose Unity Tweak Tool over it. If for any reason you don't wanna install GNOME Tweak Tool, this is how you can enable the 'Global Dark Theme' mode manually:

Step 1: Open the GTK3 configuration file in Text Editor:

gedit ~/.config/gtk-3.0/settings.ini

Step 2: Paste this into the file opened by Text Editor:

[Settings]
gtk-application-prefer-dark-theme=1

and save it. That's all! Enjoy your dark themes 😃

  • 1
    HEXcube, this is all very helpful, thank you! If I can just ask one more thing and you'll have solved my entire issue: how can you apply the dark theme to gtk 2.0 applications? with gtk-application-prefer-dark-theme=1, I can see my gtk 3.0 apps are now dark, but apps like Gimp, Inkscape, VLC player, etc. are still light. How can I get those to follow suit? – Jesse Aug 3 '16 at 22:27
  • 1
    @Jesse GNOME's 'Global Dark Theme' mode is applicable ONLY to GTK3 apps. GTK2 can't turn the dark mode on and off. So you'll need to specifically apply a GTK theme whose GTK2 part is dark. Current versions of GIMP, InkScape and LibreOffice are all GTK2, but the GTK3 versions are in development.😊 Qt based apps (including VLC) follow the GTK2 theme when running on GNOME based desktops. – HEXcube Aug 4 '16 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.