2

I just did a clean install of Ubuntu 16.04. Booting gets me to the LightDM login screen. Loging in I get a flash to a terminal entry that is too fast to read and back to the LightDM greeter. My guest session goes right to the GUI desktop with no issues. I was able to login from the terminal (CTL+ALT+F1) just fine, I then tried running the GUI from the terminal with startx. I got the following error message:

xf86EnableOPorts: failed to set IOPL for IO (Operation not permitted) xinit: connection to x server lost

I looked it up online and tried:

find ! -user $myusername

I got a missing argument usage error which I don't understand.

I also reinstalled ubuntu-desktop and unity from the terminal with no change. I did the following:

sudo rm -fr ~/.Xauthority
sudo rm -fr ~/.config/autostart

With no change.

I'm a mouse monkey who can follow instructions but I really don't know what's going on. This is obviously not a driver issue as my guest account boots fine. It's something to do with the xserver and my account on the system.

For the record my graphics card is an integrated Intel HD 4600 Graphics.

This is as far as I can get. What do I do now?

Thanks.

UPDATE 7/4/16 1:56 am

So I gave up and did a clean install of 14.04 and used the system updater to install the 16.04 distribution upgrade. This worked perfectly! I rebooted and logged in fine. NO LOGIN ISSUES! I then restored my personal files and settings by copying the files into my home profile directory and overwriting everything as root (sudo)from another drive. Everything went as expected and appeared fine. I rebooted and the problem has returned!

I now know it is something in my old 14.04 setting in MY home profile directory that is causing this issue in 16.04. Deleting .Xauthority does nothing to help the issue and has been restored. Any ideas out there? It's a something in my home folder somewhere. I need to fix it via terminal and I'm a mouse monkey. Please help.

Thanks.

2

The problem was fixed by doing the following:

Press CTRL+ALT+F1 and log in via the terminal then run:

sudo chown -R $USER:$USER $HOME

Then press CTRL+ALT+F7 and log in

for example:

sudo chown -R popeye:popeye /home/popeye/

This comes from:

https://answers.launchpad.net/ubuntu/+source/lightdm/+question/197479

Post #2 by actionparsnip (andrew-woodhead666)

Thank you Jyves. Your answer and variants of it where also mentioned at that forum post. Thankfully the answer above turned out to be cleaner in the long run and let me keep all my original files without my having to laboriously sort through them and copy them to a new user profile.

So it appears that this question is closed.

1

Given the fact your problem is with your main user and does not appear with other user, it is likely one of the hidden files within your home folder is corrupt. The trick is now to identify which one (often .Xauthority, but not in your case).
Could you login to the terminal and type: sudo adduser newuser --group sudo

This will create a new user called 'newuser' with sudo priviledge. Reboot and try to login with this new user, you should be able to login normally. From there open a file manager (dolphin, nautilus, midnight commander etc...) and visually compare the hidden files in your home folder with the hidden files in the new user folder, for example if yours is empty ( 0 byte) and not the other, this could be the one causing trouble. I'm afraid this will be a bit tedious.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.