2

I bought a Dell Inspiron 11 3000 series (model 3162) yesterday and tried installing Ubuntu 16.04 64-bit on it. Installation went fine but after it finished and restarted, it refuses to boot (doesn't recognize GRUB).

I have tried using the boot-repair tool, I have tried turning on the EFI mode, turning it off and still no luck.

Output of boot-repair is here

Also this is how my boot setup in the BIOS looks:

boot list option legacy, secure boot disabled, load legacy option ROM enabled, boot priority: USB, HDD, CD, Network, Diskette

1

It looks like it's trying to boot to your SD card. Is that where you ran boot-repair from? Trying pulling out the SD card and see if your hard disk now boots.

Otherwise, try running boot-repair from a Ubuntu Live CD. After booting a Live CD, open terminal, and enter:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

Copy and paste one line at a time. See if that fixes your problem.

Report back.

5
  • It's funny you say that cause it does run when I have my "bootable usb drive" in and boots in ubuntu but not without it. I'll try your solution and see if it works. – ubuntu_user_2007 Aug 2 '16 at 18:29
  • That's probably because boot-repair wrote GRUB out to the SD card, instead of your hard disk. Booting to the Live CD should allow boot-repair to work correctly. – heynnema Aug 2 '16 at 19:04
  • So, I am not quite sure why, but this is what I did to solve the problem in case anyone else will have the same issue. I downloaded the iso file for ubuntu 16.04 64-bit from Ubuntu website, used unetbootin to make a bootable USB drive and used it to boot my Dell. I should mention the Dell has an MMC drive. I tried different methods and installation always went well, but after installation it wouldn't boot, saying no bootable device found. Funny part was if the usb drive was connected, it'd boot to my Ubuntu (not the live mode). I tried manually to fix it using grub, but to no avail. – ubuntu_user_2007 Aug 2 '16 at 21:21
  • I also used the boot-repair in recommended and advanced mode and still no resolution. So I tried based on comment from @heynnema to use a DVD instead of a usb drive and surprisingly it worked as soon as I installed it. No boot-repair required. So I'm making a blind guess that boot/efi was being installed on the USB somehow instead of the MMC card. So solution is very preposterous but just use a disk! – ubuntu_user_2007 Aug 2 '16 at 21:21
  • Glad you got it going with the CD. The reason that it failed before was the SD/MMC was coming up as /dev/sda and your hard disk was coming up as /dev/sdb. With a CD, it comes up as /dev/sr0. Please rate my answers and click the accept checkmark. Thanks. – heynnema Aug 2 '16 at 22:36
2

Hi I too had difficulty and racked my brain over this, but was able to install from a bootable usb. Two things I had to do:

  1. I made the bootable usb from using rufus in windows and selecting for the boot scheme that it was GPT scheme with UEFI not the default MBR with UEFI optiob
  2. In the laptop boot settings, I set it to UEFI and secure boot on.

Then I when I inserted the bootable usb and turned the laptop on selected f12 for the boot options and selected the UEFI bootable drive it also showed the usb name too there. the normal bootloader came up and installed. I was asked to create a password for secure boot. Then after that I selected to erase the drive and install normally, i didn't select the 'something else' option. everything installed as normal, and when it rebooted i did have a dos menu that came up first asking me i wanted to boot normal, change secure boot options ect. i just clicked normal and everything loaded normal.

I'm actually typing this right now from this Dell inspiron 11 3162..Hope this helps anyone else having troubles with the install a lot of us seem to be having.

Update I wasn't done playing, and ended up installing Linux on another similary set up Dell, which then resulted in me redoing the 3162. This time I made the bootable disk with USB Image Writer in linux, and it worked, I just had to ensure I the boot menu set to uefi with secure boot on, in any other setting it won't boot once installed. I've now installed Linux on the 3162 twice with different OS's and 1 once on another Dell with the same set up on it.

0

I had this problem recently - secure boot settings were causing the system to boot with a black screen (it was running but displaying nothing). Leaving secure boot enabled in the BIOS but removing all the secure boot keys allowed it to boot without the black screen.

1
  • 1
    Removing all the secure boot keys? What keys? From where? How did you do that? – Zanna May 8 '17 at 4:26
0

I had a similar experience with a Dell Inspiron 11 3000 series failing to boot after an install, in this case Ubuntu Studio 17.04. The solution was to redo the installation, but starting with secure boot turned on.

Not all plain sailing at this point however: the installer failed, saying 'the 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot'.

The solution now was to install and run Boot-Repair, following these instructions https://help.ubuntu.com/community/Boot-Repair. Boot-Repair led me through a series of commands that needed to be copied and pasted into a terminal. I did not understand any of these, but it seems the effect was to install the missing GRUB bootloader. The machine now boots fine.

3
  • OP obviously ran boot repair already (they include a link to the summary report!) so are you just sharing your story? Because that's not how the site works... – Zanna May 24 '17 at 14:27
  • My apologies, I was attempting to share useful additional information that might have helped a naive user like me find a solution. Should I delete this post? – J. Simon van der Walt May 24 '17 at 20:01
  • Hmm seeing that you have the same device, I think it's probably related, so maybe you could improve your answer by briefly explaining how to "install and run boot-repair" and elaborating a little on "Following all the instructions" – Zanna May 24 '17 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.