5

I am using XFCE on Xubuntu. I want my default browser to be Chromium.

In Settings Manager > Preferred Applications web browser is set to Chromium.

In gconf-editor: /desktop/gnome/url-handlers/http and /desktop/gnome/url-handlers/https command key is set to exo-open --launch WebBrowser %s. exo-open --launch WebBrowser https://google.com launches Chromium.

note:~$ xdg-mime query default x-scheme-handler/http
chromium.desktop
note:~$ xdg-mime query default x-scheme-handler/https
chromium.desktop

But programs open http(s) links with Firefox. For example, xdg-open https://google.com launches Firefox.

How can I fix it?

UPD1: Chromium settings: "Chromium cannot determine or set the default browser."

2
  • How about if you go to Chromium's settings and make it the default browser? – Parto Aug 2 '16 at 6:53
  • what about update-alternatives --config x-www-browser ? – Zanna Aug 2 '16 at 7:16
7

Change default browser using update-alternatives --config x-www-browser:

$ update-alternatives --config x-www-browser

There are 2 choices for the alternative link group x-www-browser \
(providing /usr/bin/x-www-browser).

  Selection    Path                Priority        Status
------------------------------------------------------------
* 0            /usr/bin/firefox         50        auto mode
  1            /usr/bin/chromium        10       manual mode

Press <enter> to keep the current choice[*], or type selection number:

The current choice has a *. Just press the number of the browser you want to use. In this example I would type 1 to make Chromium the default browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.