1

I'm getting the following errors when installing Skype.

The following packages have unmet dependencies:
 skype : Depends: skype-bin
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I don't know how to remove the broken packages.

2
  • You can check any held packages by "apt-mark showhold", but I'm not sure if this is the problem. If there is any packages mentioned in your error logs are held, you can "sudo apt-mark unhold <package name>" to unhold them.
    – alfred
    Aug 2 '16 at 13:12
  • not working sir, how to check held package in error log??
    – nmajethiya
    Aug 3 '16 at 4:42
2

Since the output of uname -a gives x86_64, it means that you have a 64 bit version.

I suggest that you first try to remove traces of your skype install. You can do this by entering sudo apt-get purge skype in your terminal. It might be possible that you have to run sudo apt-get purge skype-bin also.

Then check if you have any held packets: Open the /var/log/dist-upgrade/apt.log log file in a text editor. Locate any "broken" packages and remove them with sudo apt-get remove .

Note: in newer versions, the log is located in /var/log/apt/term.log instead.

To install Skype again, you should first run following command

sudo dpkg --add-architecture i386

Add the correct repository:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"

Then update & install Skype:

sudo apt-get update && sudo apt-get install skype
10
  • I had followed above steps but it is again throwing same error, Error is : The following packages have unmet dependencies: skype : Depends: skype-bin unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed Depends: libcheese7 (>= 3.0.1) but it is not going to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    – nmajethiya
    Aug 2 '16 at 10:47
  • and uname - a returns : 4.2.0-27-generic #32~14.04.1-Ubuntu SMP Fri Jan 22 15:32:26 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
    – nmajethiya
    Aug 2 '16 at 10:49
  • @nmajethiya See updated answer
    – Noosrep
    Aug 2 '16 at 11:02
  • Since I am new to Ubuntu, can you please answer how can I see that package is broken or there is ant held packet ??? I found term.log file
    – nmajethiya
    Aug 2 '16 at 11:24
  • @nmajethiya Did you open the file?
    – Noosrep
    Aug 2 '16 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.