0

With the new sublime text version I receive:

"Package Control

Your system's locale is set to a value that can not handle non-ASCII characters. Package Control can not properly work unless this is fixed.

On Linux, please reference your distribution's docs for information on properly setting the LANG environmental variable. As a temporary work-around, you can launch Sublime Text from the terminal with:

LANG=en_US.UTF-8 sublime_text"

How can I get around this?

My locale is:

LANG=de_CH.UTF-8
LANGUAGE=de_CH:de
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=C

enter image description here

  • What is your locale? You can see it from locale in a terminal. – dadexix86 Aug 1 '16 at 22:44
  • @dadexix86: Added above. – empedokles Aug 3 '16 at 11:53
  • 1
    That's the problem. C is not good enough for sublime text. Did you use something like localepurge? – dadexix86 Aug 3 '16 at 11:54
  • I don't know what that is, I'm more of a hobbyist. – empedokles Aug 4 '16 at 13:16
  • 1
    @dadexix86: Language Support won't help in this case. The problem is that LC_ALL is set, and it wasn't done via Language Support. – Gunnar Hjalmarsson Aug 9 '16 at 12:00
0

The problem is that LC_ALL is set to "C" somewhere. LC_ALL should not be set persistently at all on an Ubuntu desktop. If it is, it overrides any GUI for setting locales/language.

I'd start to check out the /etc/default/locale file. If you find the line

LC_ALL=C

there, then open the file for editing, remove that line, and relogin.

  • It says: LANG="de_CH.UTF-8" LANGUAGE="de_CH:de" – empedokles Aug 10 '16 at 20:26
  • @empedokles: In that case you have set LC_ALL in some other config file. If you fail to find out where, one way to handle it might be to add the line unset LC_ALL to your ~/.profile file (and relogin). – Gunnar Hjalmarsson Aug 10 '16 at 21:23
  • How can I find this file? I don't remember to have set it. I upgraded from 15.10 to 16.04. – empedokles Aug 12 '16 at 7:32
  • @empedokles: ~ stands for your home directory (/home/<yourname>), so you find .profile in the 'root' of your home directory. (It's a hidden file, so if you use Files, you need to make sure that it also shows hidden files.) – Gunnar Hjalmarsson Aug 12 '16 at 17:12
  • Thanks, I will try it. BTW: The same problem on my laptop, seems ubuntu-specific. – empedokles Aug 13 '16 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.