4

Hardware : gigabyte P34Gv1 laptop

Ubuntu 16.04 ran fine with internal battery. After it inflated and was extracted ubuntu failed to boot without the said battery attached.

Recovery mode shows normal boot until usb devices. It then waits until ~240seconds from boot and spits out kworker timeout delay messages regarding acpi battery init. (I am not entirely certain where these messages are logged, couldn't find them in syslog)

Ubuntu can boot with acpi=off, but as a result I am only able to use 1 cpu core.

Bios does not allow any options regarding acpi.

Is it possible to disable battery-related features for acpi without disabling it entirely?

Edit: I have tried acpi options acpi=ht, acpi.nopower_check=1, acpi_osi=Linux without success.

Edit2: processor.nocst=1 boot option along with acpi=off does not let the system access multiple cores.

1 Answer 1

1

I managed to boot without acpi=off on a Gigabyte P34v3 with an upstream kernel (4.9.0-040900rc7), see here: https://wiki.ubuntu.com/Kernel/MainlineBuilds . ACPI still yields a lot of errors, but at least it does not prevent the laptop from booting:

[    4.035270] ACPI Error: Divide by zero (20160831/utmath-310)
[    4.035308] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC.BAT1._BST] (Node ffff8c429f0c7230), AE_AML_DIVIDE_BY_ZERO (20160831/psparse-543)
[    4.035380] ACPI Exception: AE_AML_DIVIDE_BY_ZERO, Evaluating _BST (20160831/battery-506)
1
  • Perfect, thank you! The mainline kernel did permit me to boot normally.
    – J.Dooe
    Commented Feb 9, 2017 at 11:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .