I just installed the latest ATI graphic drivers version 11.11, by first removing the old ATI drivers from jocky. The installation went smooth and afterwords i ran the commando sudo aticonfig --initial -f and restarted the computer.

I also installed Gnome-shell. Before when I was using Gnome-shell with the default Ubuntu ATI-properiataty drivers installed by Jockey, all the text in Gnome shell was messed up.

Now the text looks normal but every time I try to open the "start-menu/dashboard" the screen flickrs/flashes/blinks a few times.

Is there a way to resolve this issue?

Also, how can I confirm that it is the latest ATI drivers that are activated?

  • Open Catalyst and on the the left click information, there you can see the version you're using, and if you removed the previous drivers, it is completely safe to say you're using the ones you installed, and gnome-shell doesn't play nice with the fglrx drivers by the way. – Uri Herrera Nov 18 '11 at 22:01
  • Here is my question I have posted a few days back with the same issue. I am still using ATI 11.10 driver, and the flicker is present. As many have said, gnome-shell doesn't play nice with fglrx. I wanted to try the 11.11 driver, but you have just confirmed it that ATI hasn't solved the problem. Or better said, it's a gnome-shell issue. – bioShark Nov 18 '11 at 22:14

I had this problem and I solve it after install the last ATI graphic drivers version 11.12 you can find it in
select the one you want "my system is Ubuntu 11.10 32 bit and my graphic card is AMD Radeon HD 6400M Series" this is the link if you want it
after install it go to "Catalyst control center":->Display Options->tear free.
enable it after that apply and ok it should solve your problem.

  • hey user8580, Could you please confirm that you are using 11.12 becuase I can't find that version at AMD site. Latest version is 11.11. Desperately I need to fix gnome-shell in my AMD ATi system. – Abhijeet Dec 23 '11 at 11:27
  • Why all are using catalyst driver where open source provide best driver for AMD. Catalyst does not support suspend also. Use open source radeon driver : shantanucse.blogspot.com/2011/11/… – shantanu Mar 3 '12 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.