5

I was in the middle of upgrading to Ubuntu 16.04 and the upgrade froze about halfway through, freezing my entire computer. I had to manually reboot it, and when I did so, it loaded into the terminal and has remained there. I have full access and ability within the terminal, but I can't seem to log back into the GUI/Desktop environment. I honestly have no idea what to do at this point, and I'd really rather not wipe my computer clean and re-install Ubuntu.

Any comments/suggestions are highly welcome!

2
  • So no suggestions here??
    – Justin
    Aug 5 '16 at 14:58
  • What method were you using for upgrade? I would check that your files in /etc/apt/sources.d/ are using xenial sections of the repos. If they are then you can just reinitiate the install doing something like sudo do-release-upgrade from the command line (or even just sudo apt-get dist-upgrade). Take note of the solution re dpkg --configure -a that will handle packages which were part installed but not properly configured.
    – pbhj
    Aug 11 '16 at 11:29
3

This happened to me as well, and it was definitely frightening. Luckily it proved pretty simple to recover from. I'm far from certain on this, but perhaps it'll be the same for you? Here's what I did:

When I logged directly into my terminal, I was informed by a line above the command prompt that:

E: Error: BrokenCount > Orun-parts: /etc/update-motd.d/90-updates-available exited with return code 255

Per Ashish's answer at this link, I ran:

sudo dpkg --configure -a

Running this continued the installation process. I then had to continue to follow the output, manually choose to install replacements of certain files, and rerun the whole command once to get around a 'loop' that came up in the 'triggers'. (Let the single quotes here signify that I have very little idea what my OS is doing in this process, so I took this all at face value and just kept trudging through. NOTE: I AM NOT SAYING THIS TO RECOMMEND IT, just to explain what happened. I was just more concerned with getting back into my normal environment and ensuring that my work was backed up than with researching extensively each of the options that popped up.)

Eventually the dpkg --configure command exited without Error status. Then I was able to switch the machine off and on again and boot up in the GUI.

At that point a number of red flags went off and Ubuntu threw up a bunch of error and failure messages. I used point-and-click to navigate through these as I could, restarted once again for good measure, then opened a terminal and ran:

sudo apt-get install -f
sudo apt-get upgrade

After this, things seemed to settle down and seemed to be mostly back to normal. apt-get update currently seems incapable of running, and a number of other minor and strange behaviors are popping up (e.g. getting error messages from Floobits when I run Vim, which I've yet to research). I have a feeling that this kind of stuff will continue for a while as I smooth things out.

Importantly though, I am back in my normal OS environment and files all appear intact! :)

I am far from an expert in this sort of stuff, but I hope this helps.

D

2
+25

Don't panic. IF your home directory was in a separate partition, it is very likely you can do a clean install and still access your old files. Don't let the default installer re-partition your hard disk.

I suggest you boot the system from the USB stick, run the Ubuntu live session, use that to review the partitions in your computer. You may need to google for help on chores like running fdisk to see existing partitions, what formats they use, and you can see if your old /home is still there somewhere.

While you are in the Ubuntu live session, you can mount the old home partition and copy it to a safe place, if you did not already.

I cannot describe in more detail what to do because I don't know what kind of partitions you used. I'm still preferring to use old fashioned ext4 partitions, but if your previous install used lvm or one of the other kinds, well, you've got some googling to do.

But the key to victor for you here is to refuse to let the new install attempt to erase old partitions or create a new partition scheme. You need to use the custom install options, you choose where you want to put /boot, /, /tmp, and hopefully you find /home. Just don't let it reformat /home.

0
1

I hope you do have a backup of the data in the system that faced this problem. I'm afraid that since there is no way for anyone to know what state your installation is in, the easiest way to fix it would be to start a new installation from scratch.

The Live-CD can also be used to backup readable data from your hard disk.

1

I had similar problem with 14.04 I no idea why, but I got it fixed this way.

If you have access to the terminal you should check the following:

1.- cat /etc/apt/sources.list and /etc/apt/sources.list.d/*

Do they show up the xenial reference or still trusty? If you have xenial you might have to rerun the upgrade. If it is trusty set it to xenial.

2.- Try apt-get update then apt-get dist-upgrade. That should install and configure what is still missing.

3.- Reboot your machine

1

Hmm, if you can still do the apt-get command you can try to install ubuntu-desktop. Once its installed, reboot and if its still at the terminal, try ctrl alt f7. If it still does not work, login and type startx. Also, try doing commands such as sudo apt-get update and sudo apt-get upgrade , Or you can type this command:

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install ubuntu-desktop && sudo reboot now

I hope you can fix this all! Good luck :)

0

if you can access the terminal and you can check network connection is working (like with ping 8.8.8.8). you can then just type: do-release-upgrade as it has it's own sudo call.

I think that should fix it. if after the release upgrade finishes you still experience problems with the gui, reboot, login, then check the output of startx

0

In case another user ends up here before the reboot their system...

This happened to me too when upgrading to 16.04. Instead of rebooting, I hit the Ctrl+Alt+up arrow buttons to switch active windows. Nothing happened for about 2 minutes.

Then the command executed and the screen was unfrozen. I believe the auto-lock screen routine is what caused this so after this,

I moved the mouse every couple minutes until the update was complete.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.