2

Preface: I have a laptop with Ubuntu 16.04 / Windows 10 in dualboot and 2 external displays, one with VGA input, and another with HDMI.

Various times I'm using HDMI display as the second on Windows or Ubuntu, and everything is fine.

When I connect VGA display using Windows, all is well too. But the problem is connecting VGA display with Ubuntu,so, I can use just internal laptop screen or external VGA screen, or even mirror video on both screens, but when I try to use extend mode, all that I see is a black screen on one or another display :(

P.S. My graphics card is AMD Radeon HD 7600m, I'm using open source Radeon driver. Another weird thing: internal display resolution is 1366x768 and external VGA is 1280x1024. When I set 1024x768 instead of usual 1280x1024, it works properly. But using any other resolution leads to black screen.

xrandr output:

Screen 0: minimum 320 x 200, current 2390 x 768, maximum 16384 x 16384
        eDP connected primary 1366x768+1024+0 (normal left inverted right x axis y axis) 344mm x 194mm
           1366x768      59.93*+
           1280x720      59.86  
           1152x768      59.78  
           1024x768      59.92  
           800x600       59.86  
           848x480       59.66  
           720x480       59.71  
           640x480       59.38  
        VGA-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
           1280x1024     60.02 +  75.02  
           1280x960      60.00  
           1152x864      75.00  
           1024x768      75.08*   70.07    60.00  
           832x624       74.55  
           800x600       72.19    75.00    60.32    56.25  
           640x480       75.00    72.81    66.67    60.00  
           720x400       70.08  
        HDMI-0 disconnected (normal left inverted right x axis y axis)
  • What graphics card do you have? – Andrea Lazzarotto Aug 2 '16 at 23:34
  • @AndreaLazzarotto AMD Radeon HD 7600m. Using open source Radeon driver, since proprietary fgrlx is deprecated at 16.04 – Uroboros Aug 3 '16 at 12:17
  • @AndreaLazzarotto Another weird thing: internal display resolution is 1366x768 and external VGA is 1280x1024. When I set 1024x768 instead of usual 1280x1024, it works properly. But using any other resolution leads to black screen. Maybe it'll help to identify the problem... – Uroboros Aug 3 '16 at 12:30
  • That is relevant information, please include it in the question. Also include the output of xrandr. Finally, can you also try the proprietary driver (even if deprecated) for a moment and report if it makes any difference? – Andrea Lazzarotto Aug 3 '16 at 12:35
  • @AndreaLazzarotto I've added it to the question, including xrandr output. As for proprietary driver, I've found info that even if I want, I couldn't install it, since the driver does not support Xorg 1.18 that ships in Xenial. – Uroboros Aug 3 '16 at 13:01
0

What often works

With VGA-0 set to 1280x1024 and eDP connected. run the command (from a terminal):

xrandr --output VGA-0 --pos 0x0 --output eDP --pos 1280x0

which does what should happen automatically after you connected the second screen. The command top- aligns both screens, with eDP at 1280 from the top-left of VGA-0.

If this works, as a workaround, add the command to a shortcut key which you can press after connecting the second screen. Choose: System Settings > "Keyboard" > "Shortcuts" > "Custom Shortcuts". Click the "+" and add the command:

xrandr --output VGA-0 --pos 0x0 --output eDP --pos 1280x0

What is the issue?

Graphics drivers seem to be the bottle-neck in many minor incompatibilities. Also in many cases, we can solve it with a small workaround like above.

The exact reason for your issue might be a timing issue, the screen and the driver do not " recognize each other" in time, so the procedure breaks.

Important part is that we can subsequently persuade the system to do the setup with an xrandr command :).

  • Comprehensive answer, just need small syntax fix: --output... – Uroboros Aug 3 '16 at 13:48
  • @Uroboros aarrgh, fixed. Did it by heart. Thanks! – Jacob Vlijm Aug 3 '16 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.