17

I've got pretty much the same problem as this old 2006 thread on the Ubuntu forums: my old laptop's lid is a bit shaky, which causes the computer to wakeup/suspend if I just touch it the wrong way (e.g. lifting it up to move it).

Back then, the fix (see link) was to have a startup script disable LID in /proc/acpi/wakeup every time the computer boots. I'm wondering if there's a better, less hacky, solution?

3
  • Did they get rid /proc/acpi/wakeup in Maverick? It still exists on my Lucid system, and I don't see why it shouldn't work. Commented Oct 26, 2010 at 0:52
  • Nope it's still here, so the solution from 2006 still works. It's just a bit of a hassle to maintain. Commented Dec 16, 2010 at 6:50
  • The link is dead Commented Sep 27, 2017 at 18:21

2 Answers 2

4

Its no less hacky, but you can simplify the solution by adding echo "LID " > /proc/acpi/wakeup to the /etc/rc.local file. This way you don't have to create a startup script.

1
  • permissin denied even with sudo :(
    – Liker777
    Commented Apr 20, 2022 at 5:00
2

What about changing it to Blank screen when laptop lid is closed. This is way you will not get suspended.

System-->Preferences-->PowerManagement

1
  • 3
    Nope... this keeps the laptop running when I close the lid, but if I suspend it manually before that, it still wakes up when I open the lid. The idea is to prevent the laptop from waking up when the lid moves a bit, not preventing it from going to sleep. Commented Oct 19, 2010 at 4:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .