1

Every time I try to install any package, I get the same error. It refers to the same dependencies with any package. this causes the software center to crash.

sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 sync-my-l2p:i386 : Depends: libqt5core5a:i386 (>= 5.2.0) but it is not    installed
                    Depends: libqt5gui5:i386 (>= 5.0.2) but it is not installed or
                             libqt5gui5-gles:i386 (>= 5.0.2) but it is not installable
                    Depends: libqt5network5:i386 (>= 5.0.2) but it is not installed
                    Depends: libqt5widgets5:i386 (>= 5.0.2) but it is not installed
                    Depends: libqt5xml5:i386 (>= 5.0.2) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

The same happens every time I try to install any packages.

Output

    laptop:~$ apt-mark showhold
    laptop:~$ sudo apt-get install sync-my-l2p:i386 libqt5core5a:i386 libqt5gui5:i386 libqt5network5:i386 libqt5widgets5:i386 libqt5xml5:i386
[sudo] password: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
sync-my-l2p:i386 is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libqt5core5a:i386 : Depends: libicu52:i386 (>= 52~m1-1~) but it is not going to be installed
 libqt5gui5:i386 : Depends: libegl1-mesa:i386 (>= 7.8.1) or
                            libegl1-x11:i386
                   Depends: libgbm1:i386 (>= 8.1~0) but it is not going to be installed
                   Depends: libgles2-mesa:i386 (>= 7.8.1) or
                            libgles2:i386
                   Depends: libqt5dbus5:i386 (>= 5.0.2) but it is not going to be installed
                   Depends: libxcb-icccm4:i386 (>= 0.4.1) but it is not going to be installed
                   Depends: libxcb-image0:i386 (>= 0.3.9) but it is not going to be installed
                   Depends: libxcb-keysyms1:i386 (>= 0.3.9) but it is not going to be installed
                   Depends: libxcb-randr0:i386 (>= 1.3) but it is not going to be installed
                   Depends: libxcb-render-util0:i386 (>= 0.3.8) but it is not going to be installed
                   Depends: libxcb-shape0:i386 but it is not going to be installed
                   Depends: libxcb-xfixes0:i386 but it is not going to be installed
                   Depends: libxcb-xkb1:i386 but it is not going to be installed
                   Depends: libxkbcommon-x11-0:i386 (>= 0.4.0) but it is not going to be installed
 libqt5network5:i386 : Depends: libqt5dbus5:i386 (>= 5.0.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

A new error encountered !!!

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
  • Do you get any output from apt-mark showhold? Else try sudo apt-get install sync-my-l2p:i386 libqt5core5a:i386 libqt5gui5:i386 libqt5network5:i386 libqt5widgets5:i386 libqt5xml5:i386 and paste its output. – Byte Commander Aug 1 '16 at 9:14
  • apt-mark showhold : returns nothing. sudo apt-get install : returns the same along with few more dependencies. how to add the output. It is too long for the comment. – Atul Aug 1 '16 at 9:48
  • Please edit your answer and paste the output. – Byte Commander Aug 1 '16 at 9:52
  • the output shows dependencies of following packages. libqt5core5a:i386 : Depends: libicu52:i386, libegl1-mesa:i386 (>= 7.8.1),libegl1-x11:i386,libgbm1:i386,libgles2-mesa:i386,libqt5dbus5:i386,libxcb-icccm4:i386,libxcb-image0:i386,libxcb-keysyms1:i386,libxcb-randr0:i386,libxcb-render-util0:i386,libxcb-shape0:i386,libxcb-xfixes0:i386,libxcb-xkb1:i386,libxkbcommon-x11-0:i386,libqt5network5:i386 : Depends: libqt5dbus5:i386 – Atul Aug 1 '16 at 9:55
  • Did you try installing libqt5gui5 or upgrading it? – Hedwig Aug 1 '16 at 11:14
0

As apt-get is not able to install the dependencies, i think you have installed the software for wrong architecture. try to purge the sync-my-l2p. you could use the following commands:

sudo apt-get purge sync-my-l2p
sudo dpkg -P sync-my-l2p

then use:

sudo apt-get autoremove

If you want to install sync-my-l2p again, try to find the amd64 version.

Regards

| improve this answer | |
  • Yes this seemed to work. It works now.. Thanks mate.. – Atul Aug 3 '16 at 16:36
0

Try to upgrade libqt5gui5 using sudo apt-get upgrade libqt5gui5.

| improve this answer | |
  • yes. I tried installing every dependency along with the one mentioned above. But every apt-get install return the same dependency list. So basically, every apt-get install/upgrade isn't working!! :( – Atul Aug 1 '16 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.