1

I just installed 16.04 yesterday, and tried installing Google Chrome. I downloaded the .deb from Google, opened it with Software Installer and installed it. So far, so good.

However, when I try to open Chrome from the Launcher, the Chrome icon pops up in the Unity sidebar but no window opens. When I right click the Chrome icon and select "New Window", the Chrome icon disappears in 5 seconds.

Has anyone else faced this on 16.04?

EDIT: When I try to run google-chrome here's the output

~$ google-chrome
/usr/bin/google-chrome: line 55: /opt/google/chrome/chrome: cannot execute binary file: Exec format error
/usr/bin/google-chrome: line 55: /opt/google/chrome/chrome: Success
~$ google-chrome-stable
/usr/bin/google-chrome-stable: line 55: /opt/google/chrome/chrome: cannot execute binary file: Exec format error
/usr/bin/google-chrome-stable: line 55: /opt/google/chrome/chrome: Success
  • Run google-chrome in terminal and post output TO YOUR QUESTION. – Pilot6 Aug 1 '16 at 9:11
  • 2
    My googling suggests that the bitness of your Google Chrome may not match the bitness of your Ubuntu. Can you tell us if which of the 32-bit or 64-bit versions of Chrome and Ubuntu have you installed? – edwinksl Aug 1 '16 at 9:48
  • 1
    Yep, that's what the problem was - I'd accidentally installed the 32-bit version of Ubuntu. I did an uninstall and re-installed the 64-bit version. Thanks! – Tejas Srinivasan Aug 2 '16 at 3:27
3

Comments on the question show that, at least in the case of Tejas Srinivasan (who posted the question), the problem was that Google Chrome was the 64-bit version, but the 32-bit version of Ubuntu had been installed accidentally, rather than the 64-bit version as had been intended. A 32-bit OS cannot run 64-bit programs. Installing the 64-bit version of Ubuntu instead solved the problem.

My googling suggests that the bitness of your Google Chrome may not match the bitness of your Ubuntu. Can you tell us if which of the 32-bit or 64-bit versions of Chrome and Ubuntu have you installed?

edwinksl Aug 1 '16 at 9:48

Yep, that's what the problem was - I'd accidentally installed the 32-bit version of Ubuntu. I did an uninstall and re-installed the 64-bit version. Thanks!

Tejas Srinivasan Aug 2 '16 at 3:27

2

I also had a similar issue. Chrome did not start when I click on the chrome icon on unity, however I could run it from terminal.

Then I found the Path setting on .local/share/applications/google-chrome.desktop was set to something outside my home folder. So I set it back to the my home folder and it worked.

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Name=Chrome - Google Chrome
Icon=google-chrome
Path=/home/nterms
Exec=/opt/google/chrome/chrome %U
StartupNotify=false
StartupWMClass=google-chrome
OnlyShowIn=Unity;
X-UnityGenerated=true

Perhaps this could help someone with the same issue.

1

I had the same problem. Try running chrome through your terminal. If you get this error: nss>=3.26, then do the following:

  1. Your Ubuntu Software Center may not be working, if not, then install the previous version using this command:

    sudo apt install software-center synaptic

  2. Now open software center and type nss (or libnss) in the search box. All nss-related packages will show up. Install them all (all packages related to nss, one by one) and do sudo update and sudo upgrade, restart the computer and try opening chrome.

It worked miraculously for me.

0

After an update I had the problem.

Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files

I solved launching chrome as : /usr/bin/google-chrome

And it asked me the keyring password. After this, chrome worked normally.

I don't know why it wasn't asked before, I'd even rebooted many times my laptop. I Hope it could help someone else.

0

In .local/share/applications I had multiple google-chrome.desktop files (e.g. aaaaaa-google-chrome.desktop, bbbbbb-google-chrome.desktop, etc).

I erased them all in the hopes that chrome would correctly rebuild what it needed. It did -- now it's working.

0

I had the same problem. Had to delete $HOME/.config/google-chrome every time before launching. Switched to Chromium and had the same problem.

For those who have tried all the methods found on the Internet and still are facing this issue, here is the solution works for me:

  1. Launch Chrome with sudo: sudo google-chrome. This will change the ownership of some of the files under $HOME/.config/google-chrome to root. If you launch Chrome at this moment, Chrome will start successfully but with a pop-up message saying your preferences cannot be read.

  2. Change the ownership of these two files back to your account: $HOME/.config/google-chrome/Local\ State and $HOME/.config/google-chrome/Default/Preferences

  3. Launch Chrome again. This time there should be no problem.

  4. If you have problems with the reset of files still belonging to root, you can change their ownership back to your account now.

If this solution does not work, try turning off "Use hardware acceleration when available" in "settings".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.