I upgraded my Ubuntu Desktop 10.10 system to 11.04 and then 11.10.

Now, when I start Ubuntu, the Unity desktop doesn't start correctly. Here's what I do:

  1. Start computer
  2. I log in via the GUI login screen
  3. The X Window System starts. I can see an arrow icon for the mouse, and can move it around the screen.

Nothing else starts. There are no desktop icons, no launcher, no taskbar, etc. Right clicking on desktop does nothing. I've tried some common keyboard shortcuts ("Alt-tab" "Ctrl-Alt-T" "Ctrl-Alt-Backspace") but nothing happens.

If I go to another Virtual Console, and run the command unity, the Unity desktop will start on my primary X desktop. However I'm seeing many problems like windows which are only half-drawn, some applications run without the familiar "Minimize, Maximize, Close"

What's happening here? It seems that the X Window System started, but Unity did not start?

How can I debug this?


Solved it.

In my case, I was running the proprietary ATI drivers (fglrx) for my ATI/Radeon graphics card. At some point during the upgrade, Ubuntu installed the open source ati/radeon drivers. However, these two drivers cannot exist alongside one another See bug 285603.

From what I can tell, the proprietary ATI drivers cause problems with Xorg especially if they exist alongside the opensource ATI drivers.

This is a common problem, and the steps are pretty well documented.

To fix this, I uninstalled the proprietary ATI drivers (fglrx) using these instructions. I had to use the section called "Problem: Need to fully remove -fglrx and reinstall -ati from scratch".

Then, I installed the open-source ATI drivers instead. The open-source drivers are called 'ati' or 'radeon'. I followed these instructions:


If anyone really wants the proprietary fglrx driver, you should still consider replacing the proprietary drivers with the Radeon drivers first, so that you can make your system stable first. Once the system is stable, then try experimenting with the ATI proprietary drivers starting from a stable system.


Do a clean install of ubuntu 11.10 backup all of your files and format your drive, upgrades don't go very well sometimes. it happen to me once.

  • That's too extreme of a solution at this point. I'd rather debug & fix the existing problem instead of simply reinstalling. – Stefan Lasiewski Nov 18 '11 at 20:17
  • His problem seems to be extreme I gave him an extreme solution. nothing works so reinstall. – Engels Peralta Nov 18 '11 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.