11

I know that Ubuntu 10.04 is no longer supported.

But I am still using it, becuase I use virtual machine (VirtualBox), and on previous trials to use any more updated Ubuntu version was too heavy, and slow, in my machine.

Now, when I try doing:

apt-get update 

I receive a bunch of errors:

...
Ign http://il.archive.ubuntu.com lucid-updates/multiverse Packages
Ign http://il.archive.ubuntu.com lucid-updates/multiverse Sources
Err http://il.archive.ubuntu.com lucid/main Packages
  404  Not Found
Err http://il.archive.ubuntu.com lucid/restricted Packages
  404  Not Found
...
Err http://security.ubuntu.com lucid-security/main Packages
  404  Not Found [IP: 91.189.88.162 80]
...
W: Failed to fetch     http://il.archive.ubuntu.com/ubuntu/dists/lucid/universe/binary-i386/Packages.gz  404  Not Found

I am sure I used to do that in the past without any issues.

Is it because Ubuntu 10.04 was removed from these repositories, or is it some other issue?

  • if you not it is end of life ... why bother asking? – Rinzwind Aug 1 '16 at 6:58
  • have you tried a more lightweight Ubuntu flavour? Xubuntu, Lubuntu, or, as I understand, MATE? – user308164 Aug 1 '16 at 7:27
  • 1
    deleted my answer because I misread the question – patrick Aug 1 '16 at 7:39
  • I just had this problem in an old VM I've inherited. I added the old-releases.ubuntu.com URLs as seen at github.com/docker-library/official-images/issues/1902, to /etc/apt/sources.list. This was enough to update/install new packages. – mwfearnley Jul 21 '17 at 14:14
4

It's really trivial to verify, just browse to http://il.archive.ubuntu.com/ubuntu/dists/ (you can also drop theil from the front) and check the results.

The site is responding, you get a connection, but there is no lucid among the directories corresponding to Ubuntu releases.

Conclusion: the packages were removed.

| improve this answer | |
22

To complement techraf's answer, if you want to use old releases, you can access them using this address:

http://old-releases.ubuntu.com

To enable this, open the /etc/apt/sources.list file with a text editor, and wherever you see archive.ubuntu.com (the source of releases actively supported), change it to old-releases.ubuntu.com (you can use the find & replace option to speed it up).

| improve this answer | |
  • I tried this but still apt-get update or upgrade is not working. I am using ubuntu 10 – RAJ KUMAR MISHRA Jul 31 '17 at 17:19
  • 3
    worked relatively well for me, i had to replace us.archive with old-releases, and also 'security.ubuntu.com' with 'old-release.ubuntu.com' – don bright Aug 15 '17 at 23:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.