4

I get that this is quite a specialised concern, but I've already added 'Greek (polytonic)' to my keyboard layouts, and it works for typing certain accents and characters. I can easily type ά, ὰ, ἀ, ἁ, ᾳ, ᾶ, ᾱ and ᾰ (for any vowel) by using dead keys on [;], ['], [ and ], but this seems to be it.

I need to have some key combination for characters with an accent and a breathing/iota subscript, such as ἄ, ἆ and ᾇ. I've tried a selection of combinations which are used for the Windows polytonic layout, as well as the combinations mentioned in this document: https://docs.google.com/document/d/1oiK5KraVvob6fAEhcVjwI99RlWtnBLiSGgDFs96qrbk/edit, but the only time that pressing two keys beforehand seems to work is Shift+;/' for ἀ/ἁ.

Is there some way that I have to set up AltGr to work in the way the writer of that document uses it? I've set up the 'Compose key' to be AltGr and 'Alternative Characters key' to be Right Ctrl, but neither of those seem to do anything on the Greek keyboard. The Keyboard Layout Chart doesn't suggest there's any way of typing the characters I want.

Sorry if there's a really obvious answer to this, I'm still getting used to Ubuntu, but it's a big problem for me if there isn't a way to type these characters. I'm reluctant to try this: http://frame-poythress.org/keyboard-entry-of-polytonic-greek-and-biblical-hebrew-in-gnulinux-2014/, as the layout of the bare characters isn't what I'm used to. If necessary, would I be able to set up keyboard combinations for these characters?

χάριν ἐχω ὑμῖν in advance!

2

The Greek X11 Compose file offers multiple predefined options for typing characters as those you mention. To enable it, follow these steps:

  1. Open Language Support and select "XIM" as the input method.
  2. Unless your selected display language is Greek, open the ~/.profile config file for editing and add this line:

    export XCOMPOSEFILE=/usr/share/X11/locale/el_GR.UTF-8/Compose
    
  3. Log out and log in again.

Then, to type e.g. ἄ, one option is: AltGr+>+'+α

You can find out other options by studying the /usr/share/X11/locale/el_GR.UTF-8/Compose file.

Edit:

These are the steps with Right Ctrl as the compose key:

  1. Press Right Ctrl
  2. Type > (by holding down Shift when pressing the key)
  3. Type ' (by holding down AltGr when pressing the key)
  4. Press α

Nothing should happen on the screen until you press the α key, and then the ἄ character should show up.

  • Thanks for your reply. I selected "XIM", added the line to ~/.profile in gedit, logged off and on again, but unfortunately that combination doesn't seem to work. I just get a plain α as if no dead-key combination has been pressed. I opened up /usr/share/X11/locale/el_GR.UTF-8/Compose, but the file is blank/empty. Whilst in 'Language Support' I noticed Greek wasn't installed as a language, so I installed 'Greek, Modern (1453-)', as there was no Classical option - but a Modern Greek setting is hardly going to help me with polytonic characters, right? – chandelleverte Aug 1 '16 at 16:46
  • 1
    @chandelleverte: The file isn't empty, but the first few lines are. Just scroll down a bit, and you'll see a lot of stuff. Adding the Greek language in Language Support doesn't make a difference in this respect. I tested the above successfully without it. Please note that my example is a Compose key example (not dead key), assuming that <AltGr> is still your compose key. – Gunnar Hjalmarsson Aug 1 '16 at 17:31
  • 1
    @chandelleverte: Let me add two things: AltGr as the compose key seems not to be a good choice when using the Greek (polytonic) keyboard layout. You need the original behavior of AltGr to be able to type e.g. an apostrophe character. (When I first tested I used the plain Greek layout.) However, after having assigned Right Ctrl to the compose key instead, I could successfully use it to type the ἄ character as above with the Greek (polytonic) layout. The second thing is that you don't really need to enable the input method "XIM". The default "IBus" works as well. – Gunnar Hjalmarsson Aug 1 '16 at 18:31
  • Ah yes, silly me! OK, so I've changed the compose key to be Right Ctrl, but Right Ctrl + > + ' still doesn't seem to be producing anything but a bare alpha. I've tried it on both XIM and IBus now. I tested the compose key on the English (UK) keyboard and it seems to work, so have I bungled one of the first steps instead? Since /usr/share/X11/locale/el_GR.UTF-8/Compose does indeed seem to contain all you said it should, surely the key combinations should be working now! Perhaps there's a technique to pressing the keys I'm not familiar with? I'm rather grasping at straws at this point! – chandelleverte Aug 1 '16 at 18:43
  • 1
    @chandelleverte: Please note that I pointed you to the predefined combinations for typing Greek characters. Another variant is to create an ~/.XCompose file and make up your own combinations for a few characters. – Gunnar Hjalmarsson Aug 1 '16 at 22:21
0

Make hot keys for special characters with the compose key feature described here.

Ελπίζω ότι βοηθά!

  • Thanks for the link; the first part that concerns me is that my Keyboard Settings window doesn't even offer me 'Shift+AltGr' as a combination for the Compose key. It's currently set to be the AltGr key on its own. Also, following the instructions for 'XIM' in the fifth section of the guide, I'm afraid the /usr/share/X11/locale/el_GR.UTF-8/Compose file is empty, so there's nothing to edit in it, and /usr/share/X11/locale/compose.dir is also empty. The Unicode composition (Ctrl+Shift+U) method, which I've used for my English (UK) keyboard, doesn't seem to work for the Greek keyboard either. – chandelleverte Aug 1 '16 at 17:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.