1

I have a bunch of music CDs that I want to digitize as .m4as with album art, so that I can use them with iTunes on a virtual machine. Is there a simple way to just read the tracks off the CD in .m4a form with correct album art, titles, genre, etc?

Please no Rhythmbox answers, Rhythmbox tries to be “too smart” and vacuums up every random audio file on my hard drive (and some non-audio files, apparently it thinks .ttf fonts are songs) and just creates a bigger mess to clean up.

2

An excellent choice under either Trusty Tahr or Xenial Xerus is to use the command line ripper abcde. Installation is slightly different for each of these versions of Ubuntu:

1. Trusty Tahr Installation:

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update
sudo apt-get install abcde imagemagick glyrc fdkaac

2. Xenial Xerus Installation:

sudo apt-get install abcde imagemagick glyrc fdkaac

Usage:

Best option then is to use a suitable conf file copied and pasted into the file ~/.abcde.conf and then simply run the following command under either Trusty Tahr or Xenial Xerus:

abcde -o m4a -G

And this should be enough to rip, encode to m4a, tag, find and download album art. Consider as well the use of the MusicBrainz script that comes with abcde for even more accurate album art downloading...

References:

Full disclosure: I am a former maintainer of abcde.

| improve this answer | |
  • which encoder is best for apple compatibility? – taylor swift Aug 1 '16 at 14:22
  • okay it seems to be working, but for some reason the bitrate shown in the file properties says it is 2 kbps? Shouldn’t it be much higher than that? – taylor swift Aug 1 '16 at 15:12
  • nevermind it was the variable bitrate thing…thank you this worked fantastic! – taylor swift Aug 1 '16 at 15:22
  • ps I found a small bug in abcde, the prompt Locally cached CDDB entry found, use it [Y/n]? Y Invalid selection. Please answer "y" or "n": y doesn’t accept Y even though it offers it as one of the two options – taylor swift Aug 1 '16 at 15:43
  • @Kelvin It should accept a lower case 'y'. Not entirely clear I can see... BTW some fdkaac tips here: askubuntu.com/a/783890/57576 – andrew.46 Aug 1 '16 at 18:25
1

From the Ubuntu Software Center, you can download the CD audio ripper program Asunder.

To rip to .m4a you need to install the AAC encoding files. From the CDRipping page on the Community Help Wiki:

AAC Encoding

Enable the universe and multiverse repositories. Then, install the gstreamer0.8-faac and gstreamer0.8-ffmpeg packages to encode AAC files, and the gstreamer0.8-mad package to play them back.

Asunder will also access the freedb CD information databases and automatically fill in track information if available.

These two steps should be all that you need, though working with restricted formats on Ubuntu can present problems.

| improve this answer | |
  • i can’t install gstreamer0.8-faac & friends, I get Unable to locate package gstreamer0.8-faac. And yes, I have universe and multiverse enabled – taylor swift Aug 1 '16 at 2:27
  • Try installing the "GStreamer extra plugins" package from the Software Center – Aaron Aug 1 '16 at 2:45
  • searching GStreamer extra plugins returns no results – taylor swift Aug 1 '16 at 2:47
  • Do you have the 'restricted' box checked, along with multiverse and universe in the sources preference? They may be included in there. – Aaron Aug 1 '16 at 14:24
  • it's the same box – taylor swift Aug 1 '16 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.