1

I have problems with some packages (7 of them to be specific), and I can't solve this situation.

What's the problem?

Packages not fully installed and impossible to remove (at least for me).

What's my OS and what I do with it at now?

My OS is Ubuntu server 16.04. I Just have install it.

I also installed asterisk, openvpn, openSSH and shorewall among others.

Some information about the problem

Everytime I install or remove package, it's show me an error message of not fully installed packages that I can solve in anyway.

When I execute, as a root user, the command "dpkg --remove openvpn", the result is that:

root@ubuntu-server:~# dpkg --remove openvpn
(Reading database ... 64768 files and directories currently installed.)
Removing openvpn (2.3.10-1ubuntu2) ...
warnings.pm did not return a true value at /usr/bin/deb-systemd-helper line 84.
BEGIN failed--compilation aborted at /usr/bin/deb-systemd-helper line 84.
dpkg: error processing package openvpn (--remove):
 subprocess installed post-removal script returned error exit status 5
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 openvpn

And the same is for the packages:

  • mime-support
  • pcscd
  • opensc
  • openvpn
  • shorewall
  • grub-legacy-ec2
  • initramfs-tools

I also look into the file /usr/bin/deb-systemd-helper and founded out the line mentioned like the error line: use warnings;

What I already try to solve this?

  1. Comment lines in .posrm and .prerm files of some packages.
  2. Diffetent ways to uninstall those packages (dpkg, apt-get and apt remove, apt purge, etc.).
  3. reboot system after apt-get update and apt-get upgrade

1 Answer 1

0

Run the following:

wget http://mirrors.kernel.org/ubuntu/pool/main/p/perl/perl-base_5.22.1-9_amd64.deb
sudo dpkg -i --force-all perl-base_5.22.2-3_amd64.deb
sudo apt-get update
4
  • Your first line is a URL, not a valid terminal command. Do you mean they should download that file, then run the commands on the second and third lines? Aug 1, 2016 at 2:55
  • @NickWeinberg sorry. I have fixed it
    – fosslinux
    Aug 1, 2016 at 2:56
  • Thanks for you reply! It solve the most part of the problem. Now I got this: sudo apt autoremove Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: perl : Depends: perl-base (= 5.22.1-9) but 5.22.2-3 is installed perl-base : Breaks: perl (< 5.22.2~) but 5.22.1-9 is installed E: Unmet dependencies. Try using -f What I should do? Because I also still having troubles with dpkg --configure openvpn command. Thanks again
    – Ppica88
    Aug 1, 2016 at 13:58
  • I edited my question. Please refollow the instructions
    – fosslinux
    Aug 1, 2016 at 22:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .