6

I have nvidia-settings and nvidia-prime installed, but the 'PRIME Profiles' tab is missing.

How can I fix it to be able to switch between my GPUs?

Update:

~$ lspci -k | grep -EA2 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
    Subsystem: Hewlett-Packard Company 4th Gen Core Processor Integrated Graphics Controller
    Kernel driver in use: i915
--
01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)
    Subsystem: Hewlett-Packard Company GK208M [GeForce GT 740M]
    Kernel driver in use: nouveau

My Drivers

  • Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command. – Pilot6 Jul 31 '16 at 11:16
  • @Pilot6 Question updated. – 0lesya Jul 31 '16 at 19:10
  • You did not install Nvidia drivers, that is why PRIME does not work. Obvious. – Pilot6 Jul 31 '16 at 19:12
  • Switched to Nvidia drivers and restarted... the tab finally appeared after the second 'cycle' of reinstalling PRIME + switching between drivers + rebooting. Not sure why it didn't the very first time, as I'm absolutely sure that I had Nvidia drivers running at the time. + Not sure if the things are connected, but after my first reboot with 'PRIME Profiles' tab present, logging in took longer and a message about an internal error appeared. (ExecutablePath: /usr/lib/unity-settings-daemon/unity-settings-daemon). When I rebooted again to check if it's a constant issue, I had no such problem. – 0lesya Jul 31 '16 at 19:42
1

Install nvidia-361 in terminal or in GUI, reboot, and PRIME will appear.

It works only with NVIDIA proprietary drivers.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.