1

Running 11.10, with up-to-date Flash (11.1.102.55, which the Flash site agrees is the up-to-date version). Every Youtube video reports a blank screen with the words, "Invalid parameters":

http://gutfullofbeer.net/youtube.png

I've tried fiddling with the player "hardware acceleration" setting, and that has no effect. Similarly, I've clicked and un-clicked and re-clicked the "storage" options in the global settings thing, also to no effect.

I haven't seen this in any google searches (though there are other problems described involved the "Invalid parameters" message) which makes me think it's a recent phenomenon.

edit — hmm, fails in Firefox but works in Chrome ...

1

Maybe you already did but, have you tried "flash-aid" add-on for Firefox? It installs the best option for you. It has solved me problems several times after trying for hours by myself with no luck.

  • No I haven't tried that but I will now. Thanks! – Pointy Nov 18 '11 at 16:00
  • Worked. It's odd that the plugin seemed to work OK in Chrome. – Pointy Nov 18 '11 at 16:09
1

It doesn't technically solve your problem, but I heartily recommend trying HTML5 videos on YouTube and sidestepping this whole nasty Flash business.

You can opt in at http://www.youtube.com/html5 then most/nearly all videos will work without touching flash at all.

1
sudo killall plugin-container

and reload the page

This solution worked for me. Had incessantly been getting this particular error with videos that involved flash(html5 didn't seem to be available for them)

  • Yes, thanks for adding this - nuking the Flash container is certainly an important trick to know :-) – Pointy May 24 '12 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.