1

For Ubuntu 64 bits, printer Canon LBP2900:

git clone https://github.com/hugolpz/Canon_printer.git
cd ./Canon_printer
make -f ./download.mk
sudo make -f ./install.mk BITS=64 PRINTER=LBP2900
sudo make -f ./OS_restart.mk
sudo make -f ./install.mk BITS=64 PRINTER=LBP2900

I installed the canon lbp2900 driver in Ubuntu 16.04LTS as above instructions. But when I run sudo make -f ./OS_restart.mk command, I get restart fail error message. And I go last command is ok sudo make -f ./install.mk BITS=64 PRINTER=LBP2900.

And then I checked systems setting - printers. I see lbp2900 driver and print testing page click. Printer status show "sending data to printer" but printer is not working and silent.

4
  • echo "On restart:" On restart: sudo pkill -9 -x ccpd sudo pkill -9 -x captmoncnabc OS_restart.mk:5: recipe for target 'restart' failed make: *** [restart] Error 1 How to solve this error? Commented Jul 30, 2016 at 19:37
  • please edit your post to add more details rather than commenting on it
    – Zanna
    Commented Jul 30, 2016 at 19:38
  • Based on the OS_restart.mk file on github, all that the restart target does is re-start the ccpd service; however it attempts to do so using SysV style /etc/init.d/xxx commands, which may no longer work on 16.04 (which uses systemd). Commented Jul 30, 2016 at 22:20
  • Could you please post text files and program output listings as text, not as images? To achieve the latter you can either 1) select, copy & paste the terminal content or 2) save it to a file and use that. Longer listings (>100 lines) should be uploaded to a pastie service and linked to in the question. Thanks. Commented Oct 2, 2016 at 9:51

4 Answers 4

3

LBP2900 in 32-bit Ubuntu 16.04 (LTS)

http://www.canon-europe.com/support/consumer_products/products/printers/laser/i-sensys_lbp2900.aspx?type=drivers&language=EN&os=Linux%20(32-bit)

# wget -c http://gdlp01.c-wss.com/gds/6/0100004596/04/Linux_CAPT_PrinterDriver_V270_uk_EN.tar.gz
# tar xf Linux_CAPT_PrinterDriver_V270_uk_EN.tar.gz
# dpkg -i Linux_CAPT_PrinterDriver_V270_uk_EN/32-bit_Driver/Debian/cndrvcups-common_3.20-1_i386.deb Linux_CAPT_PrinterDriver_V270_uk_EN/32-bit_Driver/Debian/cndrvcups-capt_2.70-1_i386.deb

# lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp://localhost:59687 -E

# ls -la /dev/usb
total 0
drwxr-xr-x  2 root root     60 Dec  2 22:38 .
drwxr-xr-x 20 root root   4400 Dec  2 22:38 ..
crw-rw----  1 root lp   180, 0 Dec  2 22:38 lp0

# ccpdadmin -p LBP2900 -o /dev/usb/lp0

# ccpdadmin 

Usage: 
  ccpdadmin [-p Printer-name -o Printer-dev-path]
  ccpdadmin [-x Remove-Printer-name]


 CUPS_ConfigPath = /etc/cups/
 LOG Path        = None
 UI Port         = 59787

 Entry Num  : Spooler   : Backend   : FIFO path     : Device Path   : Status 
 ----------------------------------------------------------------------------
     [0]    : LBP2900   : ccp       : //localhost:59687     : /dev/usb/lp0  : 

# lpr -P LBP2900 testpage-a4.ps
# lpq -a
Rank    Owner   Job     File(s)                         Total Size
active  root    64      testpage-a4.ps                  7168 bytes


# systemctl status -l cups |tail -99

Troubleshooting

lpq -a |tail -n+2 |awk '{print $3}' |while read job; do cancel $job; done
ccpdadmin -x LBP2900; lpadmin -x LBP2900; rm -rf -- /var/cache/cups/* /var/spool/cups/*; systemctl restart cups; sleep 2; systemctl restart ccpd
killall -9 captmon2
lsmod |grep usblp
ps -ef|grep -E "ccpd|captmon"

lpstat  -a
lpinfo -v

Notes

  1. Never try printing a pdf as a test since it may make you feel your setup (drivers, config) is not working, whilst lpr simply cannot directly print a pdf as a test.
  2. Restart a printer itself (physically), it may really help you.
0

Here's what worked for me

System configuration : ubuntu 16.04 64 bits LBP2900 CAPT version 1.5

I followed the https://help.ubuntu.com/community/CanonCaptDrv190#Ubuntu_13.10_Install

but the printer did not work, then installed everything that was missing from here https://help.ubuntu.com/community/CanonCaptDrv190#A64-bit_Systems

after that captstatusui -P LBP2900 showed ready to print and I was able to print :)

1
  • 1
    While the links you posted may answer the question, it's best to include the important steps of any linked instructions within your answer. External links can become invalid, making your answer and Ask Ubuntu less helpful. Commented Nov 9, 2016 at 21:28
0

So it's late March 2017; how to install Canon's CAPT Driver in 64bit Ubuntu?

Canon supply a 64bit driver; just use that; it works well, as detailed here

https://forums.linuxmint.com/viewtopic.php?f=51&t=187658&p=1264107&hilit=LBP+Canon+pdc_2#p1264107

(Canon must supply all dependencies now as the 64bit driver is fine);

..... you just need to start the ccpd daemon each time you start the computer with the command sudo /etc/init.d/ccpd start

0

This tutorial made my Canon LBP2900B printer work in Ubuntu 16.04 LTS:

After clean installation of Ubuntu 16.04 my Canon 2900 refused to print. I found out a solution and will now share here with my experience.

Standard method to install driver doesn't work. To install driver manually I downloaded and unpacked them from the official web-site of Canon.

The next step was to choose between the 32- or 64-bit driver. First my decision was to use 64-bit driver, because my OS is also 64-bit. But it was a mistake, 64-bit driver refused to work. So I choose 32-bit driver, unpacked and installed two packages in the following order:

cndrvcups-common.deb

cndrvcups-capt.deb

Then I registered the printer in OS by taping in the terminal:

sudo /etc/init.d/cups restart

sudo lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp://localhost:59687 -E

sudo ccpdadmin -p LBP2900 -o /dev/usb/lp0

sudo update-rc.d ccpd defaults

After the printer appears in menu I marked him as default by right click. All these time the printer must be turned off.

Then I reboot and printer start work.

But after that appears a new problem. When I shuttdown my computer it hangs during 5 minutes. It was caused by ccpd service. So I run:

sudo systemctl edit ccpd

and added new two lines to empty file: [Service]

TimeoutStopSec=4

Then:

sudo systemctl daemon-reload

systemctl show ccpd -p TimeoutStopUSec

and it shows that the delay was shorted. Next reboot took only several seconds.

That's all.

Source: https://yrfiles.blogspot.in/2016/12/how-to-make-canon-lbp-2900-printing-on.html

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .