2

While this doesn't seem to affect performance or function in any ways, I get these errors when booting 16.04, but only when I have the proprietary Nvidia drivers installed (or possibly the AMD CPU microcode proprietary driver). The error is:

AMD-Vi: Event logged [IO_PAGE_FAULT device=02:00.0 domain=0x0011...

and then continues to show some additional numbers in sequence. See image below.

How can I make these messages go away during boot?

Running Ubuntu 16.04 x64 (Kernel 4.4.0-31-generic), Unity 7.4.0 desktop environment, AMD FX-8150 8x core CPU, 32GB RAM, 2x Nvidia GTX660 graphics cards, Nvidia 361.42 proprietary diver and microcode firmware for AMD CPU's from amd64-microcode proprietary driver.

Relevant portion of lspci:

02:00.0 USB controller: VIA Technologies, Inc. VL805 USB 3.0 Host Controller (rev 01) 
  • editing and adding the kernel version, the output of lspci and the output of sudo lshw -class display might be helpful. – Elder Geek Jul 30 '16 at 19:41
  • @ElderGeek: Kernel 4.4.0-31-generic. Getting the rest now. – Jesse Jul 30 '16 at 20:33
  • The section that matches your error is 02:00.0 USB controller: VIA Technologies, Inc. Now we should examine the output of lsusb to find the problematic device. Please edit the output into your question. Comments are far more limited in usefulness and longevity. – Elder Geek Aug 1 '16 at 12:51
  • There may be an iommu kernel parameter you can pass that will resolve this but I am by no means an expert on that. Perhaps someone else can chime in on this – Elder Geek Aug 1 '16 at 13:31
  • @Zanna suggested in the general chat room that you try the kernel parameter iommu=soft this may resolve your issue. – Elder Geek Aug 1 '16 at 16:10
5
  1. gksudo gedit /etc/default/grub

  2. edit the line that says GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add iommu=soft Resulting in something like

    GRUB_CMDLINE_LINUX_DEFAULT="quiet iommu=soft splash"  
    

    if you haven't changed kernel parameters previously

The order of the parameters doesn't matter, the spaces between them are however important.

  1. save the file

  2. Issue the command sudo update-grub

  3. Reboot

Props to @Zanna who confirmed the required kernel parameter in chat.

For a complete list of kernel parameters check https://www.kernel.org/doc/html/latest/admin-guide/kernel-parameters.html

  • I only get this error if I leave my USB WLAN Adapter pluged in while booting. If I unplug my WLAN Adapter before booting everythings is fine. Later, after booting I can plug in my WLAN Adapter and everything still runs perfectly. (MB: Gigabyte AX370-Gaming K5 - bought 2017!) – Peterling Mar 8 '18 at 17:47
  • @Peterling Did you attempt the answer above? What happened when you did? – Elder Geek Mar 8 '18 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.