0

I upgraded my 14.04 Ubuntu to 16.04 today after I was prompted to on my home screen. It took a while to download and installation. But after installation step it shows that installation has failed and reverting to preview stage.

Then it crashed and I did a forced shutdown using the power button.

After this my laptop is not booting. It gets to the Ubuntu logo screen and thereafter screen becomes black.

On the top it shows

recovering journal 1223921 files of 3927642.

I tried command line login using Ctrl + Alt + f2 and it worked but when I run apt-get update command it throws a relocation error that something is missing in libstdc++.so.6

2

Having just solved (with the help of this other discussion) what looks like the same issue, here's what I did from the terminal:

wget http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libstdc++6_5.4.0-6ubuntu1~16.04.1​_amd64.deb

sudo dpkg -i libstdc++6_5.4.0-6ubuntu1~16.04.1​_amd64.deb

then reboot and everything should be fine (at least it was for me so fingers crossed).

  • 1
    It shows unable to resolve host address 'security.Ubuntu.com' – Ankit Agarwal Jul 31 '16 at 5:40

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.