2

So if I list libertine containters and then try to destroy some I get an error message suggesting that the container doesn't exist.

Is the list command faulty or the destroy command?

listing containers

phablet@ubuntu-phablet:~$ libertine-container-manager list
puritine
vivid2

trying to destroy one container

phablet@ubuntu-phablet:~$ libertine-container-manager destroy -i vivid2
Traceback (most recent call last):
  File "/usr/bin/libertine-container-manager", line 857, in <module>
args.func(args)
  File "/usr/bin/libertine-container-manager", line 430, in destroy
destroy_container_by_id(args.id)
  File "/usr/bin/libertine-container-manager", line 416, in destroy_container_by_id
    container = LibertineContainer(id)
  File "/usr/lib/python3/dist-packages/libertine/Libertine.py", line 287, in __init__
from  libertine.LxcContainer import LibertineLXC
ImportError: No module named 'libertine.LxcContainer'

listing containers again

phablet@ubuntu-phablet:~$ libertine-container-manager list
puritine
vivid2
  • Looks like a bug. Have you tried upgrading to the latest version of Ubuntu Touch (OTA-12)? It may already have been fixed. – Stephen M. Webb Jul 30 '16 at 14:01
  • Yep, I am on OTA-12. I will look at filing a bug, and I will include the workaround that eDiviser gives below. – Jack Jul 31 '16 at 12:59
  • Filed here: bugs.launchpad.net/libertine/+bug/1609086 – Jack Aug 2 '16 at 18:58
1

To delete the containers you sould delete the /home/phablet/.cache/libertine-container directory and all of your container should be gone. If you want to remove the userdata from the containers too you should delete the /home/phablet/.local/share/libertine-container directory as well. In the non "...-container" folders there are config files for libertine itself you also can delete, if needed.

  • Thanks for that. I think there should be a libertine-container command however. – Jack Jul 31 '16 at 12:57
1

To delete/destroy a container with the ID 'vivid2' I did the fallowing:

  1. Select the vivid2 container, which shall be destroied:

    libertine-container-manager set-default --id vivid2.

  2. Destroy the selected container:

    libertine-container-manager destroy

1

It seems the error occurred because I had earlier tried to create lxc containers and the Ubuntu-touch kernel doesn't currently support this.

Details on https://bugs.launchpad.net/libertine/+bug/1609086

eDevise and Bjarne Roß both give working methods to destroy containers in their answers. The most 'correct' way is the following syntax

libertine-container-manager destroy -i container_name

As outlined in the bug comments this isn't an issue that should affect users from now on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.