0

I'm using duply on ubuntu server and I was using 1.5.5.5-1 version of duply but getting below error suddenly.

UnsupportedBackendScheme: scheme not supported in url: sftp://user@domain.com /srv
Task 'BKP' failed with exit code '23'.

So that, I've upgrade version of duply with 1.9.1-1 but still facing same error.

dpkg -l | grep python-paramiko
ii  python-paramiko      1.15.1-1    all    Make ssh v2 connections with Python (Python 2)

Can anyone assist me with this ?

  • what is the url you are using_ – Jakuje Jul 30 '16 at 8:40
  • @Jakuje target url is sftp://user@domain.com/srv, – Nullpointer Jul 30 '16 at 8:45
  • There should not be the space, AFAIK – Jakuje Jul 30 '16 at 8:45
  • @Jakuje In my actual url there is not space, it was work before week but suddenly stop it, there is nothing change in deply. – Nullpointer Jul 30 '16 at 8:48
  • @Jakuje Also check ssh:// url is also giving same error ! – Nullpointer Jul 30 '16 at 8:59
0

I've upgrade/solve following packages :

Previously package version to upgrade:

duply 1.5.5.5-1 -> 1.9.1     # Still you'll get above error, So the need to upgrade "duplicity".

duplicity 0.6.18 -> 0.6.24-1

Then may be you'll get below error in new version:

 # /usr/bin/duply opt opt_backup >/var/log/duply-opt.log
 Error: BackendException: Could not initialize backend: No module named six

Then Do it :

# pip search six
six                       - Python 2 and 3 compatibility utilities

# pip install six

If need other python module the install it like as above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.