Anybody else having an issue with Font Viewer not running? It just shows the mouse busy cursor spinning, but eventually does nothing? Is there a fix?

  • @Rinzwind, no errors when running "gnome-font-viewer" from terminal. – Jesse Jul 29 '16 at 20:00
  • please add yourself to the "affected" people :) (see the "reported" link in my answer) – Rinzwind Jul 29 '16 at 20:27
  • Added myself to the list of affected users. :) Thanks. – Jesse Jul 29 '16 at 21:54
  • 1
    Nominated this question for reopening. Basically it doesn't matter any longer, since the issue has been fixed in the archive now, but for a few weeks the workarounds have been useful for the users. My point is that when answers provide useful workarounds, questions shouldn't be considered off topic only because the root cause is a bug. – Gunnar Hjalmarsson Aug 31 '16 at 17:02

I edited the .desktop file as a workaround:

sudo sed -ir 's/^\(DBus\)/#\1/' /usr/share/applications/org.gnome.font-viewer.desktop

Normally I advise against changing package owned file under /usr/share, since such changes will be overridden at next update of the package in question. However, in this case the issue is about to be fixed with the next update of the package, and it will start working again without workarounds.

The fix for this has been released, please run

sudo apt dist-upgrade

  • 2
    Confirmed by the way: this fixes it. – Rinzwind Jul 29 '16 at 20:35
  • Ahh, I see. DBusActivatable=true was commented out. Nice find on the root cause. – Elder Geek Jul 29 '16 at 20:54
  • @ElderGeek: Not really the root cause, I think. The yakkety version of gnome-font-viewer works fine with that line. I'm about to check out if a rebuild of the source may be sufficient to fix it: launchpad.net/~gunnarhj/+archive/ubuntu/font-viewer – Gunnar Hjalmarsson Jul 29 '16 at 21:13
  • I'm pretty sure the broken launcher file was the root cause otherwise creating a new desktop shortcut as I did in the second part of my answer would not have fixed it. – Elder Geek Jul 29 '16 at 21:36
  • 1
    I'm already running on 16.04 BTW today i was trying to open a font than i realized that my font viewer is not working :( i applied your solution and it worked for me :) . – Azeem Hassni Sep 10 '16 at 22:52

Open a terminal with CtrlAltT

Issue the following commands:

sudo apt-get update
sudo apt-get upgrade
gnome-font-viewer --display=:0

As an alternative you could create a desktop shortcut for it.

One way to do this is to use the old gnome-desktop-item-edit.

First you'll need to install is with sudo apt-get install gnome-panel

Next issue the command `gnome-desktop-item-edit --create-new ~/Desktop

Fill out the fields as shown:

fontviewershorcut

It worked for me.

Source: Experience

There is an error showing up in /var/log/syslog.

Jul 29 22:07:21 schijfwereld org.gnome.font-viewer[3361]: 
Unknown option --gapplication-service
Jul 29 22:07:21 schijfwereld org.gnome.font-viewer[3361]: 
Run '/usr/bin/gnome-font-viewer --help' 
to see a full list of available command line options.

I did not find a bug reported on this on launchpad.

It only happens when starting it from "dash" not when started from command line. So use that for the time being.


Reported.

I am not sure why it does not work on a longterm release..(Gnome 16.04.1) However, this led me to discover font-manager

sudo apt install font-manager

It took a long long time to load when I started it, but it eventually worked and then was no problem subsequently. To install fonts, you can click rightmost icon on the lower icon row and dump a whole directory all at once (using CTRL+A). It is a little slow, but it is sort of like a washing machine..dump the stuff inside and then come back later. Awesome.

screenshot

Got this bug while installing Symbol font.

Seems to be reported to LaunchPad as bug 1717678.

For myself I fixed this bug by installing font from MATE Font Viewer (part of mate-control-center package).

MATE rocks again.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.