0

According to Ubuntu's community documentation,

[...] in a UEFI-mode installation, Ubuntu will not ask you where to install the boot loader. If it does, or if it complains about the lack of a BIOS Boot Partition, you've probably accidentally booted in BIOS/CSM/legacy mode.

However, when I tried installing Ubuntu Gnome 16.04 in the UEFI mode, it asked me to select a disk or a partition for the boot loader. I chose the /boot partition. I do not know if it really installed some "boot loader" to that partition, but it also created /EFI/ubuntu folder on the EFI system partition, and Ubuntu shows up in the UEFI boot menu. When I load Ubuntu, it mounts EFI system partition as /boot/EFI.

Is this an installer bug? If not, how does it agree with the documentation that I quoted?

P.S. This is one of a few anomalies I encountered in trying to set up a multi-boot system, I included more details in my another question.

  • With UEFI, it does not matter what you say, it will install grub2's efi boot files to the ESP on drive seen as sda. If you do not have an ESP on sda it fails. I have installed multiple times to sdb and full installs to external flash drives and no matter what I say it overwrites my sda ESP's /EFI/ubuntu folder. But you always should specify a drive for grub boot loader install. The ESP is for UEFI, a /boot partition is rarely required, but is for Ubuntu's grub menu & kernels. Normally you just have a /boot folder inside the / (root) partition. – oldfred Jul 29 '16 at 21:02
  • @oldfred, this looks like a bug in the installer's interface then, and does not agree with the community documentation. – Alexey Jul 29 '16 at 22:12
0

As @alexey has already suggested in the comments (but I’m not allowed to comment), it indeed seems like a bug in installer that still persists. I could confirm it in the installer of Xubuntu 19.04. The documentation statement quoted above also still exists. I did double-check that legacy mode is disabled and the live medium was booting in UEFI mode. Expecting that it doesn’t have an effect, I left the choice of boot loader installation target at the disk root. The installation worked without issues. I did it on Dell Inspiron 11 3162 alongside Windows (select “something else”) where I was replacing Ubuntu 17.04 that was previously installed.

Partitioning dialogue in the installation process showing a drop-down menu for the boot loader installation device:

Partitioning dialogue in the installation process showing a drop-down menu for the boot loader installation device

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.