0

After an update that included the kernel and a reboot, X no longer started for my Ubuntu 14.04 machine. An attempt to startx manually failed as well with this message:

screen shot

Note: the underlying issue has been addressed by a more general question and answer and is linked in my answer below.

4
  • @Pilot6, I think it is not a duplicate but a special case with more detail on that case. When I ran into the problem, I initially searched for terms that would have led me here; I found your more general question/answer only after looking more carefully at my output and logs. – Ulrich Stern Jul 30 '16 at 10:13
  • There are lots of these "special cases". No 3rd party modules are loaded with SB enabled. Nothing is special with Nvidia. – Pilot6 Jul 30 '16 at 10:55
  • @Pilot6, the specific (special) case I am addressing is that "X no longer starts," the problem I had. Having this question/answer may help some people find a solution faster. Do you have a suggestion what I could improve? – Ulrich Stern Jul 30 '16 at 16:38
  • 1
    The answer is good. But it is not surprising that X does not start when nvidia is not loaded. – Pilot6 Jul 30 '16 at 16:48
1

The line

modprobe: ERROR: could not insert 'nvidia_352': Required key not available

had the right clue. In a nutshell, the new kernel appears to not load unsigned third party modules (the Nvidia driver in my case). Disabling Secure Boot in the UEFI (BIOS) settings solved the problem. This answer helped me disable Secure Boot for my ASUS board a little faster.

This answer has good background, a possible alternative solution, and mentions the problem starts with kernel 4.4.0-20. In my case (Ubuntu 14.04), the kernel that caused problems is 3.16.0-77.

Not the answer you're looking for? Browse other questions tagged or ask your own question.