I am new to linux/ ubuntu and just downloaded the v11 of ubuntu to learn linux. I faced this "No root file system is defined" error while trying to install it. This is how I was proceeding -

  1. Downloaded ubuntu v11 from the ubuntu.com website, wrote the iso into a bootable cd, and then got into the linux installation process on restarting; everything fine till here.

  2. In one of the screen during installation, there are three choices - install alongside windows, something else etc.. Since I have windows 7 in the C drive, I selected the first option - "Install alongside another OS".

Let me interrupt here to give my existing system details - HardDisk size: 640GB. Number of existing partitions - 5 C drive - label windows - 160GB - has windows 7 installed D drive - label linux - 160GB - does not have any data E drive - label backup - 100GB - has some data F drive - label entertainment - 100GB - has some data G drive - label work - 90GB - has some data All of the above are in NTFS format.

  1. In the screen that follows, an image is shown with 2 parts and each part is shown to have size equal to 80GB. There is a horizontal slider in the middle of these two images, with which I can resize the partitions. The right side partition is labeled Linux. There is also an option to do 'advanced partitions'.

  2. On clicking advanced partitions on the above screen, a new screen is shown in which the partitions existing in my computer are shown - but the labels are different. I see that there are two partitions with size = 160GB each (as expected), and so I assumed that the first 160GB would be my existing C drive and the second on would be the partition which I had labeled as linux (drive D). So I selected the linux partition and clicked on proceed/ install now, and then this error was shown - "No root file system defined".. and I cannot proceed after this.

Please let me know two things here:

  1. During the screen in point number 3 above, the image with slider was shown. Which partition (drive c: or d: or anyother) is being referred to here? Which one am I actually resizing - is it the existing c: drive which has windows 7 installed already, that is getting shrunk and then ubuntu getting installed in the remaining space?

  2. What does ""No root file system defined" error mean? How do I select the proper partition and continue with the installation?


I had already partitioned my drives as mentioned above, and the D drive with 160GB was specifically left free for installing ubuntu. I would like to Select D drive during setup and install ubuntu here, while still keeping the already installed windows7 in C drive.



8 Answers 8


Make sure that the partition file system you wish to install Linux, Ubuntu or Backtrack on it is ext4, ext3 or ext2, and not FAT32 or NTFS.

Then mount / on it:

  1. During the installation process press "change" on the partition you wish to use

  2. Make sure "do not use this partition" scroll is not chosen, scroll to ext4, ext3 or ext2

  3. On the "mount" field write /

  4. Click ok, then next a message will appear saying something like "swap area was not defined, do you wish to continue or choose a swap area?", click "ok" and continue or click "go back" and choose another partition and click change, on the file system scroll choose "swap" and click "ok" and next

This will solve both "no root file system is defined" and the "swap area" message, if you still get the swap area message then on step 4 mount /swap to the partition

  • if you take a look at this you will see that the partition file system is ext4 May 15, 2012 at 17:14
  • @ErrolGongson You need to set the mount point in the installer. This is the cause of our error message.
    – nanofarad
    Aug 12, 2012 at 20:14
  • 1
    Like this answer better - explains what needs to be done.
    – Samik R
    May 27, 2013 at 1:55
  • this is the only solution that worked for me, however after changing the partition to ext4 i dont see that partition any more when i am logged into windows and since i am new to ubunto i think I dont see it the partition in ubunto as well, is this what is supposed to happen? Dec 29, 2014 at 19:06

To answer your first question, the partition proposed to be split on the first screen was your windows partition. Since you already have created a partition for Ubuntu, you don't want to do that.

You say that you selected the partition on the advanced screen, but simply clicking on it does nothing; you need to click on the edit button and assign the partition a filesystem type ( use ext4 ) and mount point.

The error is because you did not assign any filesystem to be mounted in the root directory ( / ) and therefore, there is nowhere to install to.

  • 1
    thanks @psusi for answering both questions. Well, I am yet to try out the actual installation, but then going by the other responses and yours, it seems I was missing the "/" :) Thanks everyone.
    – arun nair
    Nov 19, 2011 at 4:59

continuing from @binW's answer,

If you are ready for some adventure, which might become a nightmare if proper caution is not followed.

enter image description here

enter image description here

enter image description here

You need to define the mount point specifically as / for it to function as root file system.

enter image description here

Swap you can keep, but literature tell you to keep it!! FYI, I don't have a swap.

Image source

  • This was it for me. Thank you! Courious why a blank value in that dropdown is even an option... "/" should just be the default!
    – Ty.
    Dec 23, 2014 at 17:51
  • You are welcome. IMHO, blank value might be default, if you just wnat to format a space and not use it for any purpose, as in a backup disk. Dec 26, 2014 at 5:50

To anyone who stumbles acorss this question...this was my solution.

sudo apt-get remove dmraid
  • This fixed it for me as well
    – William Z
    Sep 2, 2012 at 21:45

You must create a swap partition and space for the filesystem (ext4) partition with the '/' sign as the root filesystem.

  • Thank you Ashkan. Adding the "partman-auto/method string regular" and "partman-auto/disk string /dev/sda" helped to solve the above problem. Jan 19, 2012 at 10:11

If you find yourself having a empty partition list during the installation, you might have a problem with the dmraid module which is loaded if your system has an RAID controller (build in).

I had this issue during the installation and after pressing Ctrl+Alt+F1 to switch to the console, ran this command:

sudo apt-get remove dmraid

switched back (Ctrl+Alt+F7), I could continue the installation and had my partitions listed.


Ubuntu, or any Linux distro for that matter, requires at least two partitions to run. One is called swap and is used as swap space for virtual memory. It is not mounted any where. The other partition is used for root file system and is mounted to / i.e root of the file system tree. If you are not familiar with the linux filesystem and dont know what mounting means in context of linux then plz read this. It will help you understand these concepts.

Now about the error that you see. It is because you are not defining any partition for the root file system. As you have said that you are a new user, I would recommend that you just simply delete the partition that you have reserved for Linux (using windows) and then while installing Ubuntu select to use all available free space for Linux.

  • 1
    swap is not needed now-a-days...if you don't need to hibernate... Nov 18, 2011 at 12:30
  • 1
    Keep the swap partition just in case. Nov 18, 2011 at 13:07
  • Swap is needed!!! However, newer versions of Ubuntu use a swap file instead and a swap partition is only needed if you hibernate. I don't care what anybody tries to tell you, swap is needed to prevent your ram from maxing out. If you want to speed up read write time, consider using a separate drive for swap or just switch to a SolidState drive. Eliminating swap can cause endless disk paging that can grind your system to a halt under heavy ram usage.
    – mchid
    Feb 11, 2020 at 9:20

Maybe you have a problem with the ISO you downloaded. Try to find the MD5 of the .iso in the site and compare with the one you downloaded.

I already had Mandriva Free 2010 on my hard drive when I installed Ubuntu 12.04, and in the installation everything worked fine for me.

Not the answer you're looking for? Browse other questions tagged or ask your own question.