1

Internet connection drops after some random amount of time which changes from seconds to 15 minutes. However, wifi is still connected at full strength. I have to disconnect and reconnect every time when this happends. Searched the internet.

That problem still continues.

How to solve this problem?

Operating system: Ubuntu 14.04

Result from lspci -nnk | grep -iA2 net; iwconfig:

07:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a] (rev 34)
    Subsystem: Intel Corporation Centrino Wireless-N 1030 BGN [8086:5305]
    Kernel driver in use: iwlwifi
0d:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
    Subsystem: QUANTA Computer Inc Device [152d:0873]
    Kernel driver in use: atl1c
lo        no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"No Service"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: FC:4A:E9:38:99:0B   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=68/70  Signal level=-42 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:69   Missed beacon:0

eth0      no wireless extensions.

Result of ./wireless-info when internet connection is ok: http://paste.ubuntu.com/21463166/ Result of ./wireless-info when internet connection is dropped: http://paste.ubuntu.com/21465233/

Note: However, this time internet connection came back without reconnecting after a short amount of time.

0

I would change the channel your wifi is on as there are 10 access points on channel 1

Channel occupancy:

  10   APs on   Frequency:2.412 GHz (Channel 1)
  1   APs on   Frequency:2.427 GHz (Channel 4)
  5   APs on   Frequency:2.437 GHz (Channel 6)
  1   APs on   Frequency:2.447 GHz (Channel 8)
  1   APs on   Frequency:2.457 GHz (Channel 10)
  7   APs on   Frequency:2.462 GHz (Channel 11)

You can see the wifi channels in use from the script results. I would also change the SSID to No-Service eliminating the space in the name.

There is a another network with the same name, possibly a guest. I would change this to No-Service2, giving it a unique name and eliminating the space. Also change the encryption to match as this one has TKIP enabled

Cell 01 - Address: 
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=59/70  Signal level=-51 dBm
Encryption key:on ESSID:"No Service" Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s 24 Mb/s; 36 Mb/s; 54 Mb/s Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s Mode:Master Extra:tsf=0000000004b54ad8 Extra: Last beacon: 88ms ago IE: IEEE 802.11i/WPA2 Version 1 Group Cipher : CCMP Pairwise Ciphers (1) : CCMP Authentication Suites (1) : PSK Cell 02 - Address: Channel:1 Frequency:2.412 GHz (Channel 1) Quality=29/70 Signal level=-81 dBm
Encryption key:on ESSID:"No Service" Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s 9 Mb/s; 12 Mb/s; 18 Mb/s Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s Mode:Master Extra:tsf=0000009216a456e8 Extra: Last beacon: 88ms ago IE: IEEE 802.11i/WPA2 Version 1 Group Cipher : TKIP Pairwise Ciphers (2) : CCMP TKIP Authentication Suites (1) : PSK

The issues I saw in your wireless script was a crowded channel 1 and having 2 access points with the same name and your computer was jumping from one to the other

[  241.663063] wlan0: authenticate with 
[  241.663537] wlan0: send auth to  (try 1/3)
[  241.665598] wlan0: authenticated
[  241.665740] wlan0: waiting for beacon from 
[  241.927534] wlan0: authenticate with 
[  241.934607] wlan0: send auth to  (try 1/3)
[  241.963944] wlan0: authenticated
[  241.968113] wlan0: associate with  (try 1/3)
[  241.986164] wlan0: RX AssocResp from  (capab=0x431 status=0 aid=3)
The 'No Service' [AC1] is the one with the stronger signal in the script results and the preferred encryption. 'No Service' [AC2] has TKIP encryption enabled.

When those changes are done your wifi may benefit by changing the module parameter with

echo "options iwlwifi 11n_disable=8" | sudo tee /etc/modprobe.d/iwlwifi.conf

Reboot

| improve this answer | |
  • I have a wifi repeater in the house. The second one with the same name is the repeater. I cannot change its name as it uses the same name with the original network. But i will try using another less crowded channel. – zarax Jul 30 '16 at 20:44
  • I changed the channel and so far the Internet has dropped only once. That is a great improvement. Thanks. – zarax Jul 31 '16 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.