11

I have a dell vostro 14-5480 laptop installed Ubuntu 16.04. I recognize that after suspend, my wired connection does not work anymore. I tried restart network-manager service by sudo service network-manager restart and a solution from Webupd8 and also here but none of them solves the problem. Here is my result from sudo lshw -C network

  *-network               
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: eth0
       version: 10
       serial: 20:47:47:63:b9:b3
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168g-3_0.0.1 04/23/13 ip=192.168.1.2 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:45 ioport:e000(size=256) memory:f7204000-f7204fff memory:f7200000-f7203fff
  *-network DISABLED
       description: Wireless interface
       product: Wireless 7265
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: wlan0
       version: 59
       serial: 60:57:18:be:2e:5e
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-31-generic firmware=16.242414.0 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
       resources: irq:48 memory:f7100000-f7101fff

Thanks for any help.

8

I found the solution is that it needs to install r8168 driver.

Just run sudo apt install r8168-dkms and restart the computer.

3
  • 1
    Also worked for my HP Elitebook, same Ethernet HW, running Ubuntu 16.10/17.04. Thanks a lot!
    – kasi
    Apr 22 '17 at 18:31
  • Dell XPS 15 (L502X) checking in on Ubuntu 17.04. Seems to have worked. Sep 17 '17 at 14:14
  • Also work for Ubuntu 18.04. This is nicer than download the r8168 from realtek website and rebuild the kernel
    – dragon2fly
    May 5 '18 at 15:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.